Go Back   SEAT - SEAT Forum » SEAT Model Specific Discussion Forum includes Members Projects » Leon » Leon Mk1

Leon Mk1 Use this forum for Leon specific topics, for 2000-2005 models only

Thread Tools Rate Thread Display Modes
Old 13-08-2007, 16:04   #1
Full Member
neil's Avatar
Join Date: Jan 2002
Location: Grimston
Posts: 283
neil has 10 points
Symptoms of loose/worn top mount ??

What would the symptoms of a worn top mount be ?? Clutching at straws now with the rattle from the front offside wheel arch !!!
neil is offline   Reply With Quote
Old 15-08-2007, 00:31   #2
Posts: n/a
Hi mate

I have the same problem but on the near side front.

Dealer checked my car over for an hour, ball joint , bushes droplinks almost everything and found zilch - Never charged either (well impressed).

But now some 500 mile on its now really bad over bumpy surfices so im gonna get the top mount checked out tomorrow.

  Reply With Quote
Old 01-02-2010, 14:43   #3
Full Member
Join Date: Oct 2006
Posts: 138
conkerman has 10 points
Could be a knacked spring...

conkerman is offline   Reply With Quote
Old 01-02-2010, 15:46   #4
California Bound
JamJay's Avatar
Join Date: Feb 2008
Location: The Surrey Hills, Sweden & San Diego CA
Posts: 4,963
JamJay has 20 points
I have the same issue on the N/S. From inside the car it sounds like the rear bush on the wishbone (judging by the location of the sound) but it had it's MOT and nothing was found. I asked about it and the guys checked it over again, pushing the shock up and spring, leavering the wishbone, ARB & top mounts too but still nothing. If anything, the O/S rear wishbone bush is wearing but it's as quiet as iit should be. I am contemplating getting a new arm as it's annoying me loads!
/// Stage 3 BMW 135i
JamJay is offline   Reply With Quote


« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)

(View-All Members who have read this thread : 93
adam cupra 20vt, adm013, Adz87, Alzak, andycupra, angelday, AP2000, arge, Arkaig, Artmasterx, ash101, Bakes100, benny91, bildo, billyhas, blackcupra180, blue51, Captain Cupra, cjhawker, conkerman, Cupraken, Cupratimmy, dannyshep, daz_pd, dgmx5, downrodeo, EssexIbiza1985, foxes, FRESHMODE, frfred2009, G2, gac, gazsutton, Genoc, gingerben, GREG_R84, hazzagrant, Irie, james walker, jamesypyk, JamJay, jcullen88, Jedcupra, Jirwin, Jon-Boy, Jonnyp14391, klemenmico, LCRnorwich, leon1p, LeonCR, libiza2007, Loony R, markbrum, matty85, Mattyboy1, matylad, mike000, MooRzy, muks11, n11tht, Nautilus, Oliveracc, PlatinumR, probee, psycho6285, qwert, RaggedLob, Raks, Random1989, Razzario, Redemption, redevo1, rix, rob - 73, Ronin225, Roohul, rsmith, scottfr, seat_lion, selfagg, sexynips, sheffboy, somie2k, stump, Tom-FR, Tyler_, UncleFester, Veyron, wayne lcr, wedgie27, wieselmad, Williamleon, Willie
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ibiza Cupa - worth upgrading the front mount? Jamesemt TDi Tuning 10 07-06-2007 16:50
front mount on mk3 ibiza! smiler220 Ibiza Mk3 61 27-04-2007 10:04

All times are GMT +1. The time now is 01:16.

Website © 2014

Disclaimer: is not an official SEAT site and is not affiliated to SEAT in any way. Visit the Official SEAT Website. are not directly responsible for information which maybe posted in this forum.
All content is viewed and used at your own risk. We do not warrant the accuracy or reliability of any of the information.
The views expressed herein are those of the individual contributors and not necessarily those of or SEAT
All trademarks and copyrights remain property of their respective owners.