2011 Bocanegra Cruise Control Not Working

May 10, 2022
11
0
Hi first post here, bought a 2011 Bocanegra back in December and the cruise control has recently stopped working. The first time it stopped for about a week then came back and now it seems to be gone for good as it’s been a few months, I’ve tested the wires in the stock and they seem to be working fine and plugged in a code reader but no luck any ideas? I’m a bit lost with this one lol
 

300bhpdaily

Active Member
May 26, 2020
1,230
543
Hi sometimes there is a switch on the brake pedal or clutch pedal that fails which doesn’t cause any problems until you want cruise control and stop start for car with it. Might be worth researching that for you specific car as I don’t know what setup that has. I want to say it’s a clutch pedal switch but for the life of me I can’t actually remember as honestly never had to do this repair yet.
 
May 10, 2022
11
0
Hi sometimes there is a switch on the brake pedal or clutch pedal that fails which doesn’t cause any problems until you want cruise control and stop start for car with it. Might be worth researching that for you specific car as I don’t know what setup that has. I want to say it’s a clutch pedal switch but for the life of me I can’t actually remember as honestly never had to do this repair yet.
Hi it’s a dsg so no clutch pedal but for the brake switch do you think it would still effect the cruise control even if the brake lights are working?
 

300bhpdaily

Active Member
May 26, 2020
1,230
543
Hi it’s a dsg so no clutch pedal but for the brake switch do you think it would still effect the cruise control even if the brake lights are working?
I’ve no idea that’s the part you’d need to research yourself mate. The cruise control needs certain things to be active to engage.
money of which is the car needs to know your going above a curtain speed another is that your not braking to stay active the other things I’m not sure as I haven’t ever had to repair this fault sorry. Do a quick google search. Failing that have the car scanned by a garage who has a full version of a diagnostic software what can look into individual areas of the car not just engine fault codes.
 
Last edited:
May 10, 2022
11
0
I’ve no idea that’s the part you’d need to research yourself mate. The cruise control needs curtain things to be active to engage.
money of which is the car needs to know your going above a curtain speed another is that your not braking to stay active the other things I’m not sure as I haven’t ever had to repair this fault sorry. Do a quick google search. Failing that have the car scanned by a garage who has a full version of a diagnostic software what can look into individual areas of the car not just engine fault codes.
Those switches seem pretty cheap I might just replace it and see what happens worst case I get a new sensor out of it lol.
 

CW92

Moderator
Staff member
Jul 6, 2021
101
26
I have had the cruise fail due to a broken brake switch as previously mentioned
One way to check the brake switch in the Bocanegra would be with the car in Park or neutral with the handbrake on, then come off of the brake and see if the Brake Pedal Symbol appears on the dash or not.

(Number 14 in the image)
1654420058568.png
 
  • Like
Reactions: Cameron3100
May 10, 2022
11
0
One way to check the brake switch in the Bocanegra would be with the car in Park or neutral with the handbrake on, then come off of the brake and see if the Brake Pedal Symbol appears on the dash or not.

(Number 14 in the image)
View attachment 32156
Yeah I still get icon 14 in park or neutral I’ve checked most things I can think of at this point it will probably need to go to a garage unfortunately.
 

CW92

Moderator
Staff member
Jul 6, 2021
101
26
Shame the cruise control isn't orange when it is not engaged but turned on by the stalk. When it doesn't engage is it by using the "down" to set, "up" to resume or both?

Also when it doesn't engage do the other stalk functions work as expected (Indicators, High beam flash and High beam constant)?
 
May 10, 2022
11
0
Yes when using the down or up buttons to resume/set nothing happens. Originally this was intermittent and the cruise control stopped working for a day then came back but now it’s been gone for about 2 months. Also the other functions of the stock still work. I’ve also checked the connections within the stock as I’ve heard that they sometimes get dirty contacts but they where clean and getting good conductivity.
 

dm222

Active Member
Dec 7, 2013
1,422
39
Happened to me... It was the clutch sensor, found out measuring blocks with VCDS
 
Nimbus hosting - Based solely in the UK.