• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.
  • We're live with the new site! Please let us know what you think in this thread. Also let us know if you spot any quirks.

altea will not lock

grrf

Active Member
Jul 8, 2018
21
1
hi folks I was wondering if you could help me.
this morning my car fails to lock all the doors either with the fob or the key itself,
No noise from the solenoids when pressing lock,but does make a noise when pressing unlock.
Also the lights on the centre console locking/unlocking switch do not light up.
The key only locks the drivers door no others
It unlocked and locked fine last night .
I have read through some relevant posts,but this has confused me a little more as no threads seem to mention all these ailments
does this sound like the control module or the wires through the door jamb to any of you?

Many thanks in advance grrf.
 

grrf

Active Member
Jul 8, 2018
21
1
edit to add, I also dont think the anti hijack is triggering if this helps with a diagnosis and I dont think the drivers door lock solenoid is making a noise just the other 3
 
Last edited:

Jimbobcook

Blue... Oh go on then
Staff member
Moderator
Nov 24, 2012
5,460
1,988
Rutland
Sounds like you need to get it plugged in with a code reader to see what's going on.

Do you have a spare remote key to try and if so you could try and re program it.

You're best bet as I see the doors don't lock after 10mph you need to get it plugged in to a code reader.

Where abouts are you based?
 

grrf

Active Member
Jul 8, 2018
21
1
hi jimbob , no I have no spare blipper key ,just the none blipper,I agree with getting codes read ,am based in stoke on trent , but with no job at mo(disability) this has really peed me off.

Pretty certain the battery in keyfob is ok as it lights up and also can here solenoids when press unlock , but nothing when press lock
 

grrf

Active Member
Jul 8, 2018
21
1
And as if by magic,everything is working again this morning.Very wierd,bu not unexpected with this car tbh :snack:

Wondering if the heat had just caused something to expand and not contact properly .
 

grrf

Active Member
Jul 8, 2018
21
1
It certainly does! all the usual suspects,snapped cables in front doors...check, broken metal water tube in rear wash wipe ...check, boot solenoid kaput...check! siezed windscreen washer spindles...check! front scuttle that fills with leaves in the autumn...check 2 NEW COIL SPRINGS(THANKS COUNCIL POTHOLES) ...check!
however it has never broken down, in 115,000 miles,had the occasional limp home/overboost,but I am thinking turbo probs needs a clean, next job ...
 
  • Like
Reactions: Jimbobcook

grrf

Active Member
Jul 8, 2018
21
1
My thinking is it must of been heat expansion in one of the electrical contacts in the drivers door which was baking in the sun on sunday,almost to hot to touch..black cars !!!!
 

grrf

Active Member
Jul 8, 2018
21
1
wasn't heat, found it is the brown wire inside the bellows of the drivers door, so if you car fails to lock and indicators fail to flash , this may be the culprit
 

grrf

Active Member
Jul 8, 2018
21
1
removed rubber bellows from a pillar side,gently pulled on each wire ,however even when touched them back together it is still not locking so have just removed the door interior(pita) andf now going thru all wires
Yellow and red wire also has a cut in the insulation,putting stiffheavy gauge wire thru a door is a stupid idea imo.I might go back to aircooled stuff, way way easier to fix and diagnose.Even my mk1 gti was way easier.Hoping I have just blown a fuse to explain why it not working when touch them back together,

Whoever designed the locking wiring sockets on these cars needs shooting.
 

grrf

Active Member
Jul 8, 2018
21
1
still more fun than watching england lose to belgium for the 3rd time in 3 weeks ...
 

grrf

Active Member
Jul 8, 2018
21
1
might just aluminium line the interior of the doors instead of putting the proper door interior panel back in,completely over engineered.And this is the only ever car I have had without waterproof membranes in the doors, whats that all about?

oh god.now my soldering iron fails to work.. what a lovely day
 
Last edited:

grrf

Active Member
Jul 8, 2018
21
1
ok central locking now all working, interior panel back on drivers do ,but I have a question, how do I cancel the airbag light which is on due to the wiring loom having been removed whilst it was resoldered and repaired?

Is it simply a case of cancelling it with a software reader , or is there any way I can do it with just a sequence of turning it on and off again( like in toyotas) or would disconnecting the battery for a while sort it out , many thanks in advance.
 
Last edited:
DPM Performance