Door unlocking issues - NOT the module! Version2

Jfox

Active Member
Nov 8, 2012
395
3
Hi all,

I have been struggling to solve this issue off and on since October and its driving me mad.

I have the common fault of the passenger door not opening on the central locking fob.

Initially i thought, yes easy fix as before and bought a new unit from SEAT (£156) only to find out that did not fix the issue.
Next I have swapped the drivers lock module today in a hope that that would fix the issue... sadly not!

I did some further research and found the drivers door module controls the central locking and replacing that should fix the issue.

Now i need to know where else to go. Is it the wiring loom going from lock to inside the car?
Could it be the Body Control Module? that is the only thing wrong, i am not getting any other faults or anything showing up on scans.

I really need help with this one. I am getting the car ready for sale in the next couple of months and need it fixed.

Thanks
 

[email protected]

Back older greyer and less oilier but always hope
Jun 19, 2001
12,370
26
Gloucester
Don't ask me where exactly sadly but I seem to remember there was a way in vagcom to read the lock switch status 1 n 0 to diagnose door lock operation

I'll dig about as I've written it down somewhere

Time being check inside the rubber tunnel between the door and the car. Might just be a broken wire in there ?
 

Jfox

Active Member
Nov 8, 2012
395
3
Hi Flapper,

Thats my next check which I'll tackle tomorrow.

Luckily a 2nd hand loom from ebay is only £20.
 

ChocoMilkShark

Active Member
Jul 25, 2018
85
5
on mine, I have the option to have all my doors open on the single press and all to open on a double press I can change it all to open on a single press via the control options in the cluster. check to see if it opens on a double press if so u just need to change the settings via your options on the cluster screen thing.
 

Jfox

Active Member
Nov 8, 2012
395
3
Just to restart this threat.

Still no luck. I haven't got around to changing the wiring loom. Still trying to narrow down what else it could be.

So far there are two options:

Wiring loom in passenger door
Body Control Module

Any advice on what else it could be? The door definitely makes a sound when you look and does sort of make a sound when you unlock but nothing actually unlocks.

Could i have maybe fitted the lock wrongly- i wouldnt think so, this is the 4th lock i've fitted doing various things and i believe it can only be fitted a certain way.

I have been offered by SEAT for them to scan it at a lovely cost of £76. I guess i could bite the bullet and do it.
 

Head on Fire

Active Member
Sep 4, 2007
20
2
Preston , Lancashire
I had the same issue on my Mk2 drivers door . I changed the lock it worked for a few times then the fault came back. A friend who works for Vauxhall said it was common for a wire in the rubber between the door and car body to break. I checked and did indeed find a broken wire !
It not the easiest to get at but managed to find and solder a new piece in without removing anything . Just pull back the rubber cover to see the loom.
 

Jfox

Active Member
Nov 8, 2012
395
3
I cant find a broken wire unfortunately.

I took the rubber plug/cover off and moved it as much out of the way and nothing i can see is broken.

Il check the drivers side in case its linked but i am at a loss.

Maybe vagcom would give me an idea?
 
Nimbus hosting - Based solely in the UK.