• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.
  • We're live with the new site! Please let us know what you think in this thread. Also let us know if you spot any quirks.

Not the usual rear wash/wipe leak question..

Lippo

YNWA
May 8, 2006
395
0
Formby
Hi,

I've noticed my rear washer started leaking again a couple of weeks ago. I didn't seem to leak as much as before and it was still getting a good jet of water onto the rear screen.

I took off the bootlid trim (for the millionth time..) and saw that the washer pipe was still firmly attached with the jubilee clip I put on a few years ago.

I found that the water is leaking from the black plastic piece of plastic which is directly in line with the washer on the outside. I tried to seal the small holes/channels in the plastic thingy but the water started coming out of the wiper motor housing.

Another thing I noted was that the washer jet started moving round with the windscreen wiper, rather than staying in situ.

I've searched the forum without success. Any ideas? I'm guessing I'll have to remove the whole thing...:cry:
 

krussel

Active Member
Oct 31, 2008
1,713
2
Hertforshire
This happened on my Polo the washer nozzle turning with the arm. At first it was ok but in the end the water leaked into the motor housing and buggered the motor.

I bought a 2nd had motor from the bay for about £23 delivered and the prblem never happened again till i px the car 3 years later.

You can try wd40 etc but once mine had gone it was gone. :(
 

Lippo

YNWA
May 8, 2006
395
0
Formby
Cheers for that - looks like I'll have to replace it. Tried WD40 but didn't make any difference. Prob have to get a recon motor.
 
Nimbus hosting - Based solely in the UK.