Radio reception problems

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
So, OEM unit radio reception is fine , tunes all stations no issues - This is the Aura unit as I understand. But after market unit (xtrons and Sony) no radio what so ever, just static. I installed one of those booster things no difference at all.
Am I missing a trick ? or am I **** out of luck ?
 

Andrewwright

Turbo lover
Aug 16, 2016
1,562
221
Peterborough
So, OEM unit radio reception is fine , tunes all stations no issues - This is the Aura unit as I understand. But after market unit (xtrons and Sony) no radio what so ever, just static. I installed one of those booster things no difference at all.
Am I missing a trick ? or am I **** out of luck ?
Doesn't the standard antenna have power supply for the head unit. Im sure I've read that somewhere

Sent from my Nexus 6 using Tapatalk
 

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
This car !! - So I'm stuck with the OEM (Aura) head unit - I have tried 3 different aerial amplifiers and 3 head units - All the same no radio or incredibly poor to useless radio reception.
Put the Aura back in and its perfect.......................
 

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
Not another aerial but another car - my Kia. Got to give up now - Wifes job just gone tits up so no money to do anything - wont even be getting an oil change now either
 

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
So 180 mile trip today without radio or music of any kind - I'm desperate now ...
Do I just get the code for the Aura (OEM) and refit that - At least I would have a radio.
Do I get one of those bluetooth adapters that uses the CD input for around £80
Do I get a "new" dab/bluetooth headunit , remove the old aerial and wiring , get a new aerial and then spend days pulling the car apart and rewire it - including having to remove the head lining (which terrifies me)
 

martin j.

Active Member
Feb 11, 2007
1,337
459
Fife
Was the Sony unit new? Could it be ffaulty, can you try it in another car or even beach test using a battery and a single speaker? Does the unit log on to a station on the display? Is there a reset button on the unit?
Had a dead flat battery in the Honda and the radio was asking for a firmware update yet I couldn’t get this to work, emailed Kenwood who advised the reset( tiny button recessed requiring a cocktail stick behind the facia) all good now.
 

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
So
Sony unit was new about 5-6 years ago , have tried it in my other car (Kia ) tunes fine (finds a good number of stations and they are crisp).
No reset I can see - But will look again today.
 

martin j.

Active Member
Feb 11, 2007
1,337
459
Fife
Ok, if the unit works fine in the Kia the problem must lie with the Seat, is the aerial plug ok and making good connection with the socket, does the Sony need an earth via the casing? This is a strange one.
 

Gokiwi64

Geriatric Member
Apr 26, 2014
1,292
644
Hockley, Essex
Sorted !!
1. Purchase cheap bluetooth/dab/radio mechless head unit
2. Purchase various adaptors - get jiggy with soldering iron and heatshrink
3. Purchase Audi am/fm aerial amplifier

Fit the above (well dab aerial mounted to front windscreen) test - it all works !!

4. Throw Sony and xtrons head units in the bin
5. Order complete dab/satnav/amfm roof aerial - Do NOT pay attention to delivery time :-(
 
Number 1 Plates banner with a number plate graphic