Tunnel Run

Feb 26, 2013
523
0
Just under a week to go hopefully we can get some more cars in attendance to make it a good meet!!!
 
Jun 13, 2008
1,513
0
Kent
After doing a quick checkup on the car and removing the panel that feeds air into the air box, I think I discovered that the previous owner may have fitted an aftermarket filter and with that panel removed it sounds pretty decent, bring on the tunnels :p
 
Feb 26, 2013
523
0
After doing a quick checkup on the car and removing the panel that feeds air into the air box, I think I discovered that the previous owner may have fitted an aftermarket filter and with that panel removed it sounds pretty decent, bring on the tunnels :p
I'm going quote that "bring on the tunnels"
 
Jun 13, 2008
1,513
0
Kent
Go for it bud :)
I'm not too sure if I should go tbh. Car is idling rough as feck and majorly down on power :(
Noticed oil leak at top of oil filter housing, but don't know if this leak would cause this
 
Jun 13, 2008
1,513
0
Kent
Guy at garage said its misfiring and more than likely a coil has gone so nothing major, looking promising for the weekend :)
 
Jun 13, 2008
1,513
0
Kent
Big problems :( replaced an ignition coil but still rough garage said with more fault codes. Could either be vanos/seal needs replacing or cam sensor or crank sensor but need to go to bmw to pin it down to which one
 
Jun 13, 2008
1,513
0
Kent
I'm holding out hope its just the Cam sensor which is £50 odd to replace. P0014 code could also mean cam timing over advanced. Going to BMW after work today and hoping it'll be an easy fix :(
 
Feb 26, 2013
523
0
I'm holding out hope its just the Cam sensor which is £50 odd to replace. P0014 code could also mean cam timing over advanced. Going to BMW after work today and hoping it'll be an easy fix :(
The joy of cars!!!

Fingers crossed for you buddy
 
Jun 13, 2008
1,513
0
Kent
Booked into bmw tomorrow and will run diagnostic and hopefully fix. If they can't then I'm out of the game for tunnel run
 
Jun 13, 2008
1,513
0
Kent
Update if anyone's interested: disconnected the exhaust cam sensor and started it. Made no difference to the running of the engine, response revs etc. so I'm guessing its that sensor that could be faulty. Just hope bmw have one in stock :)
 
AP Autostyling