Help needed! Radiator Fan sound..

Sep 18, 2020
3
0
Hi!

Thanks for taking the time to read this thread. I am not a car person admittedly so if I get any parts wrong or misstate anything I apologize in advance!

I have an 'issue' with my radiator fan. My car is still under the SEAT used and approved warrantee so recently I took it back to be checked out and the dealership reported no errors or faults with any parts. However that being said I have had many issues with this dealership withholding information and sending me all around the world for answers to other problems which is why I am a bit cautious to listen to them then they say it is fine.

In short when I turn my aircon on in the car without the engine being on, the aircon works perfectly and has no issues. However once the engine is turned on the radiator fan starts running on high (it is always around 12/13 seconds off and 3/4 seconds active) and will repeat this indefinitely until the air con is turned off. I find it strange that the fan only ever comes on for this long repeatedly (the seconds never change it is always the exact same length of time) and that this doesn't happen when the engine is off. It doesn't matter if the car has just started or whether it has been running for hours, the exact same fan speed and timing turns on regardless. Is there any chance that anything is faulty or shorting as the dealership has stated that is just the way my car is but my friends car of exact same year and make produces no noise at all.

I do have video evidence is that would help. Appreciate any answers/help you guys can give and please try keep it dumb for me!!

Thanks,
Nathan
 

RADIOTWO

Active Member
Mar 6, 2018
392
65
North Derbyshire
Hi!

Thanks for taking the time to read this thread. I am not a car person admittedly so if I get any parts wrong or misstate anything I apologize in advance!

I have an 'issue' with my radiator fan. My car is still under the SEAT used and approved warrantee so recently I took it back to be checked out and the dealership reported no errors or faults with any parts. However that being said I have had many issues with this dealership withholding information and sending me all around the world for answers to other problems which is why I am a bit cautious to listen to them then they say it is fine.

In short when I turn my aircon on in the car without the engine being on, the aircon works perfectly and has no issues. However once the engine is turned on the radiator fan starts running on high (it is always around 12/13 seconds off and 3/4 seconds active) and will repeat this indefinitely until the air con is turned off. I find it strange that the fan only ever comes on for this long repeatedly (the seconds never change it is always the exact same length of time) and that this doesn't happen when the engine is off. It doesn't matter if the car has just started or whether it has been running for hours, the exact same fan speed and timing turns on regardless. Is there any chance that anything is faulty or shorting as the dealership has stated that is just the way my car is but my friends car of exact same year and make produces no noise at all.

I do have video evidence is that would help. Appreciate any answers/help you guys can give and please try keep it dumb for me!!

Thanks,
Nathan
Hi Natan
first thing the Aircon will not work with the Engine off(yes it will switch on) but will only cool when the engine is running, and I would say the fan will pulse on and off .
unless you don't get cooling then I wouls not say there is a problem so don't worry about it
 
  • Like
Reactions: NathEllis98
Sep 18, 2020
3
0
Hi Natan
first thing the Aircon will not work with the Engine off(yes it will switch on) but will only cool when the engine is running, and I would say the fan will pulse on and off .
unless you don't get cooling then I wouls not say there is a problem so don't worry about it

Thanks for the response, it has been bugging me as I wasn't sure if the dealership was holding back info on me!
It sounds like a very loud hoover, is that okay? If so thanks for the help and putting my mind at ease. :)
 

RUM4MO

Active Member
Jun 4, 2008
7,317
810
South Scotland
Hi, as said above, also try setting the AC demanded temperature to Lo, the car should get cold and the condenser fan should run continuously as the system load for cooling and so the heat being dumped out into the fridge gas has increased.

The behaviour of the fan will depend on the present demand for chilling the air and the fan will only run at High speed - that is what is causing the fan to run On and then stay OFF - etc etc..

Unless your friend's car has a different type of A/C ie one of you has manual A/C and the other has auto A/C I'd expect both car to behave in the same way if the A/C demanded temperature was set to the same value.
 
Sep 18, 2020
3
0
Hi, as said above, also try setting the AC demanded temperature to Lo, the car should get cold and the condenser fan should run continuously as the system load for cooling and so the heat being dumped out into the fridge gas has increased.

The behaviour of the fan will depend on the present demand for chilling the air and the fan will only run at High speed - that is what is causing the fan to run On and then stay OFF - etc etc..

Unless your friend's car has a different type of A/C ie one of you has manual A/C and the other has auto A/C I'd expect both car to behave in the same way if the A/C demanded temperature was set to the same value.

Perfect, I will try look at it later and see how it reacts when I change the settings on it. Do you know how loud the front radiator fan should sound?

It is a relief to see that it is not an issue and that I can stop stressing!
 

RUM4MO

Active Member
Jun 4, 2008
7,317
810
South Scotland
Quite loud - what ever that means! A lot of the time that fan, when only cooling the engine while in a traffic jam, will only run at its SLOW speed, but if the A/C is on and demanding cooling, then it will run at FAST speed.
 
Progressive Parts, performance parts and tuning specialists