Heater core problems again!! Any advise

hewittinspain

Active Member
May 27, 2017
62
4
I made another thread on here a few months ago as I had lost some heating on the drivers side and then eventually I was losing coolant a few times probably when the dpf was doing a regen and was backing things up.
Anyway I have bought a new heater core and my mechanic friend fitted it via the workaround (glovebox) and has completely flushed the coolant a few times which took him a couple of hours. I picked the car up yesterday and the heating was nice and hot. Anyway ive driven it on the motorway today, put the heating on and the drivers side is luke warm again. Im so gutted.
What is going on??? He previously did a pressure test and checked the water pump
Im losing all confidence in the leon because I know this has had problems with the heating core and the silicone bag but we have just replaced the heating core for a brand new one.
Im frightened now that it will only be a matter of time before I get more coolant loss. Ive already spent money on trying to get this fixed.
Any advise he can try?!!
 

Walone

Active Member
Feb 10, 2016
1,086
245
Near Heathrow
I made another thread on here a few months ago as I had lost some heating on the drivers side and then eventually I was losing coolant a few times probably when the dpf was doing a regen and was backing things up.
Anyway I have bought a new heater core and my mechanic friend fitted it via the workaround (glovebox) and has completely flushed the coolant a few times which took him a couple of hours. I picked the car up yesterday and the heating was nice and hot. Anyway ive driven it on the motorway today, put the heating on and the drivers side is luke warm again. Im so gutted.
What is going on??? He previously did a pressure test and checked the water pump
Im losing all confidence in the leon because I know this has had problems with the heating core and the silicone bag but we have just replaced the heating core for a brand new one.
Im frightened now that it will only be a matter of time before I get more coolant loss. Ive already spent money on trying to get this fixed.
Any advise he can try?!!
It is possible that one of the heater flaps is not working properly, assuming you have auto aircon as each side is controlled separately, best to get a scan done with VCDS or OBDeleven.
 

BoomerBoom

Active Member
Jun 1, 2018
490
177
There is a reset you can try, to see if the flaps are just out of alignment. Also change the temp from hot to cold, over and over to see if this cleans the resistive tracks.

To reset press and hold both the AC and 'air to face' buttons at the same time until the lights start to flash, when the flashing stops the process is complete.

 

hewittinspain

Active Member
May 27, 2017
62
4
I saw this reset and I tried it tonight and the heating has remained hot. I think this has helped solved the issue (touch wood). Thanks for your help
 
  • Like
Reactions: Walone
SEATCUPRA.NET Forum merchandise