Launch control Cupra 290?

Nov 19, 2020
6
1
Hi,

I recently bought a Cupra 290. I cant get launch control to work properly. I know I have to set the car in cupra, set DSG to Sport, turn off traction control and then press the brak en built the boos to 4000rpm. But it does not say something like "launch control activated" and it does not feel like it is launching the car, just a bunch of wheel hopping.

Any tips?
 

CairoCupra

Active Member
Jun 28, 2020
12
17
instagram.com
Hi,

I recently bought a Cupra 290. I cant get launch control to work properly. I know I have to set the car in cupra, set DSG to Sport, turn off traction control and then press the brak en built the boos to 4000rpm. But it does not say something like "launch control activated" and it does not feel like it is launching the car, just a bunch of wheel hopping.

Any tips?
What I do is Cupra mode + Traction off and then left on brake and right on gas (at this point you’ll see on the dash a launch control message), let it build up, let go of the brakes and DON’T mash the gas, keep throttle at like 35%-ish throughout 1st and 2nd gears then continue to apply more pressure as you shift into 3rd and so on.

It’s also good to keep it in sport (auto) and not in manual the first couple of times you launch it so you sorta get a feel for when the car chooses to shift so you later on can emulate that should you feel like you want to do it manually.

That learning curve worked well for me.

However; after launching the car like 5 times total I stopped doing it completely as honestly the wheels just spin (I’m on Conti’s and roads in Cairo are poop/dusty) or it jerks and hops.

Hope this helps out a bit.
 
Nov 19, 2020
6
1
What I do is Cupra mode + Traction off and then left on brake and right on gas (at this point you’ll see on the dash a launch control message), let it build up, let go of the brakes and DON’T mash the gas, keep throttle at like 35%-ish throughout 1st and 2nd gears then continue to apply more pressure as you shift into 3rd and so on.

It’s also good to keep it in sport (auto) and not in manual the first couple of times you launch it so you sorta get a feel for when the car chooses to shift so you later on can emulate that should you feel like you want to do it manually.

That learning curve worked well for me.

However; after launching the car like 5 times total I stopped doing it completely as honestly the wheels just spin (I’m on Conti’s and roads in Cairo are poop/dusty) or it jerks and hops.

Hope this helps out a bit.
I never get the message for launch control... Thanks for the tip on the 35% gas, I floored it....
 
Nov 23, 2020
2
1
I picked up my 290 2016 dsg Friday! Absolute animal of a car. I had the same issue. What I do is put the car into cupra mode and put the dsg down into sport, left foot on the brake... hold the traction control button down for a few seconds until the stability control turns off also, then right foot down release the brake and off u pop. I’ve got Conti sport 5s on and I still spin up in seconds n just about catch in third. What sort of mpg is everyone getting?
 

Zer0

Active Member
Jun 22, 2019
475
222
I never get the message for launch control... Thanks for the tip on the 35% gas, I floored it....
Yeah it should say "Launch Control Active".

Gearbox must be in "S". Traction control must be off. You need to press the brake pretty hard for it to be activated.

Mine being AWD I give it full throttle all the way for a 0-60 time in 3.7-3.8s, lovely sensation. :) With the FWDs you need to feather it more of course.
 
  • Like
Reactions: Cuprabenwytm

NotSoSimple

Simple
Mar 3, 2017
225
12
Suffolk
Yeah make sure you hold the TC button down for 5 secs or more until it fully turns off. it will ding

It doesnt work for me without doing this. Just pushing the button is not enough.
 

Dannnnn

Active Member
Dec 9, 2018
351
160
Hampshire
There is no "launch control active" message.
You'll know if it's doing it because bit will sit and hold the revs up.

If you jump in without it in sport or cupra, not up to temp and with TC on and hold the brake and accelerator you'll feel the difference.

Sent from my Pixel 5 using Tapatalk
 

Zer0

Active Member
Jun 22, 2019
475
222
There is no "launch control active" message.
You'll know if it's doing it because bit will sit and hold the revs up.

If you jump in without it in sport or cupra, not up to temp and with TC on and hold the brake and accelerator you'll feel the difference.

Sent from my Pixel 5 using Tapatalk
Of course there is. You just don't have the Virtual Cockpit.
 

Dannnnn

Active Member
Dec 9, 2018
351
160
Hampshire
Of course there is. You just don't have the Virtual Cockpit.
That's right I don't.
Okay so in non virtual cockpit cars there is no message.

As the OP didn't specify that he had one in the OP we aren't to know just saying cupra 290 doesn't tell the whole story (mine's a Cupra 290 but from 2016)

Sent from my Pixel 5 using Tapatalk
 

Zer0

Active Member
Jun 22, 2019
475
222
Yes, you were suggesting / correcting me that there is no message, which is false.
 
Progressive Parts, performance parts and tuning specialists