Pd130 stutter at 3k

Leeoncupra

Active Member
Feb 12, 2017
717
153
Halesowen
Hi all

Posting here as you knowledgeable 1.9tdi may be able to help

I've got a pd130 converted caddy

It has a stutter/hesitation/shudder at exactly 3k rpm

Under load it struggles to rev past it
Stationary you can feel the engine misfire as it hits the 3k mark before it revs round to redline

Any ideas?



Sent from my SM-G950F using Tapatalk
 

iammooks

Active Member
Nov 27, 2018
954
508
I don't have a solution, but just to say that I have the same issue. I've got the PD150 ARL and I've got the same stutter, usually on the way down when I'm either off the gas or downshifting.

It's possible it's the turbo, which I'll be cleaning tomorrow, so will report back then, but I've also heard some people talk about a similar stutter on their petrol engines and it didn't go away after a map, so it might be a 'feature' somehow.


Sent from my iPhone using Tapatalk
 

Leeoncupra

Active Member
Feb 12, 2017
717
153
Halesowen
I don't have a solution, but just to say that I have the same issue. I've got the PD150 ARL and I've got the same stutter, usually on the way down when I'm either off the gas or downshifting.

It's possible it's the turbo, which I'll be cleaning tomorrow, so will report back then, but I've also heard some people talk about a similar stutter on their petrol engines and it didn't go away after a map, so it might be a 'feature' somehow.


Sent from my iPhone using Tapatalk
The van has had a new turbo

It's like it's a fuel cut , il update my progress in this thread as I try solutions

Its had the egr deleted already

Next step is fuel filter , then intank pump and the tandem pump

Sent from my SM-G950F using Tapatalk
 

iammooks

Active Member
Nov 27, 2018
954
508
When I started noticing it, I thought at first it would be the injectors. I've run a fuel additive injector cleaner through in December of last year too and I can't say that's made a difference.

I've also noticed one of the fuel lines is leaking, so will be replacing the ones I think it might be.

Between us I'm sure we'll narrow it down.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Leeoncupra

Rich.T

Active Member
Feb 15, 2020
900
464
Good luck both.
Im a big fan of the PD so will be watching with interest 👍
 

Cuprabenwytm

Active Member
Jun 17, 2020
154
58
Take it to darkside and while its there get em to make it a 350 brek beast

Sent from my MRD-LX1 using Tapatalk
 

SteveWM

Active Member
Jul 12, 2016
141
46
West Midalnds
Had you thought about camshaft? I had similar rev issues which, after doing all the other good suggestions above, it turned our to be some holed followers and a couple of cam lobes 2mm less than they should be.

I have to say mine was making odd wheezing noises through the air box.

Good luck


Sent from my iPad using Tapatalk
 

iammooks

Active Member
Nov 27, 2018
954
508
Had you thought about camshaft? I had similar rev issues which, after doing all the other good suggestions above, it turned our to be some holed followers and a couple of cam lobes 2mm less than they should be.

I have to say mine was making odd wheezing noises through the air box.

Good luck


Sent from my iPad using Tapatalk

That's not what I wanted to hear - I thought I'd managed to avoid those cam issues.

Was it a big/expensive job to sort out?


Sent from my iPhone using Tapatalk
 

SteveWM

Active Member
Jul 12, 2016
141
46
West Midalnds
Well it was a choice of fix it or scrap it, PD150 FR+ in platinum, too good to scrap so had not a lot to loose really. I’m a pretty good home mechanic, I only needed to get the camshaft locking kit but had everything else.

Camshaft with bearings and followers Kit and other parts, gasket, assembly fluid were around £150ish all in. Took a couple of days as I was being careful. Went back together a treat and is still puring away (for a diesel anyway!) for my brother now.

I did a post on here couple of years ago, shows the state it was in.

Not saying it’s deffo your issue but it certainly wouldn’t Rev but ran rough and ticked over.

Hope you get it sorted


Sent from my iPad using Tapatalk
 

verbal_kint

Active Member
Apr 15, 2010
637
30
North West Kent
Any codes showing?

I've got the PD130 and not experienced that as such, similar though when the EGR was blocked and the butterfly would stick. Also been a long while but I think I had similar when the vacuum actuator set nut loosened.
 

Leeoncupra

Active Member
Feb 12, 2017
717
153
Halesowen
Any codes showing?

I've got the PD130 and not experienced that as such, similar though when the EGR was blocked and the butterfly would stick. Also been a long while but I think I had similar when the vacuum actuator set nut loosened.
unforunatly no codes at all

Is that the set nut on the turbo?

Sent from my SM-G950F using Tapatalk
 

Leeoncupra

Active Member
Feb 12, 2017
717
153
Halesowen
Shame no code as at least it could have put you on a path.

not on the Turbo itself but the wastegate: I really doubt it is that but...
Exactly my same thought, at least I knew where to start!

Well I've just had my map altered and had the egr deleted out of it to remove the engine light as its had a full egr delete but still does it

Sent from my SM-G950F using Tapatalk
 

smutts

Active Member
Apr 12, 2020
107
59
Does the PD have hydraulic tappets?

Mechanics pub story. Snopes.com might be required.
Mate once had a car with weird misfires.
Eventually he found the oil pump relief valve was stuck,
& the high oil pressure caused the hydraulic tappets to hold the valves slightly open causing it to missfire above idle.

Might be essence of cow.
 

smutts

Active Member
Apr 12, 2020
107
59
What are the symptoms if the injector wiring break down under the valve cover? Possible wiring shakes at 3000rpm, but you would get a fault code?
 

Leeoncupra

Active Member
Feb 12, 2017
717
153
Halesowen
I'm pretty sure it would through a code up due it being electrical something to do with voltage would be a good guess

Perhaps I need to log everything on vagcom to track it down

Anyone in the west midlands/stourbridge?

Sent from my SM-G950F using Tapatalk
 
EBC Brakes Direct - picture of brake discs and pads