Seat Exeo issue troubleshooting - boot won't unlock, window buttons won't work, weird alarm sounding.

Nov 4, 2021
Hi all, I've been scouring the forums for an answer to my issue and whilst there are threads for some of my Exeo's individual symptoms I need help deciphering what could be causing all of my issues at once. I'll summarise the issues at the end in a TL;DR.

Basically I went away for 5 days and left my car parked my parents private drive as its a safer spot to leave it than where I live. No issues with it when I left it there. My mum drove it once whilst I was away as well with no issues.

Then, one night it woke them up with an alarm going off and all of the interior lights on. They apparently couldn't get the alarm to stop sounding or the lights to turn off even from the key in the ignition. Eventually the alarm stopped but the lights stayed on, my Dad locked the car and hoped they would go off by themselves. When he got up in the morning they were off. (Turns out the alarm sounding wasn't the normal alarm but something to do with the alarm backup batteries? as we worked out later.)

Now when I went to pick the car up after my trip it wouldn't start and no lights or anything worked and it wouldn't unlock from the key fob. The boot also wouldn't open.
So I hooked it up to a trickle charger and left it overnight. When I went back this morning it still wouldn't start and the trickle charger showed an error. So just to check it hadn't been knocked by a cat or something I reconnected it and left it most of today.

When I went back the charger was far from finished from charging the battery but the car started, I had lots to do so I figured it would charge up from driving and then I can put it back on later if needs be. I noticed the boot still wouldn't open, but also now that the none of the electric window controls worked (on any door) though the wing mirror controls worked. The dash was also showing the bonnet being open even though it was closed, and also that the passenger door was open when the drivers door was open?! After stopping and starting the engine a few times it started to show the correct door as open, but still showed the bonnet as open. So I decided to drive it and see if it sorts itself out, however before I've even gone 50 meters I notice all of the lights inside the car are coming on, fading out, coming on, fading out, and then finally stopped at a weird half-glow. The dash still shows the bonnet as open so I think right I can't drive this car and park it back on the drive.

So I think maybe the boot mechanism being broken is causing the lights to all come on and off, so I google it and find someone saying that it might need lubricating. So I open the boot from the inside and try the Seat-logo handle and its obviously not doing anything to mechanism. Except randomly maybe 30s later I hear something inside the mechanism move, but the lock itself doesn't lock/unlock. So I take it off and lubricate it and see if it works by hand and it all seems to work fine. So I figure the electrical part of the locking mechanism might be broken (the Seat logo part) so I disconnect it to see if the issues go away. They don't.

So at this point I figure I'll leave it there, charge the battery more and try and find a replacement of the Seat Logo part of the boot locking system and see if thats the issue - if it isn't I'll return the part. And literally as I'm walking away from the car thats back on the trickle charger, a strange alarm starts sounds, one I haven't heard before. Its not making the lights flash and its clearly coming from the boot area. Putting the key in the ignition and turning it doesn't stop it and all the lights are on inside. My dad tells me that thats the alarm he heard during the night. After googling this I found someone say that this can be caused by the batteries inside the alarm itself running out or something, so I set about taking the alarm out so it doesn't wake my parents up again and so I can replace them if I need to.

So to summarise, the car:

  • had a flat battery, potentially caused by this mysterious alarm and lights coming on
  • boot mechanism doesn't work (the electrical half)
  • the windows won't roll down, no matter which door control you use
  • an alarm sounds, but not the usual one, a simpler one
  • the bonnet shows as being open on the dash despite it not being (I also cleaned the locking mechanism of this)
  • won't lock or unlock from the fob
Thanks in advance for any and all help, I'll obviously hang around to answer any other questions!
Nov 4, 2021

So the car battery is now fully charged and holding its charge as it should, however all issues still persist. I've been doing some more sleuthing on these forums and have found a lead that I believe might explain my issues.

This thread:

So my battery was sat in water. The spot I parked the car was under a big tree that is losing leaves, and the weather was solid rain whilst I was away. This leads me to believe that my ECU and CCM probably got wet.

I've removed the grommet so water drains from now on, I'm leaving it on trickle charge and hoping it might dry out a bit in the sunshine today but if not I guess I'll start trying to troubleshoot both my ECU and CCM.

Does it sound like I'm on the right track?


Active Member
Feb 15, 2011
Halifax west Yorkshire
if it has rained heavy the water could have overflowed into the front passenger footwell (via the pollen filter housing) the water could have destroyed the control unit under the front passenger seat i suggest pulling the carpet back to see if its wet under there & check the control unit while youre at it common fault on the EXEO im afraid im pretty sure that unit controls the windows/central locking ETC
Nov 4, 2021
So I went looking for the CCM and found under the carpet was very wet, with an awful burnt smell coming out. So I took out the CCM to find that the plastic connectors were fried onto the pins on the board, and the board itself is totally ruined. Looks like I'm fitting a new CCM and dealing with having to pair my keys etc...
SEATCUPRA.NET Forum merchandise