• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.
  • We're live with the new site! Please let us know what you think in this thread. Also let us know if you spot any quirks.

Connects2 Aux Input CTVSTX002 - Not Working

RVP09

Active Member
Sep 24, 2009
130
0
Hi. I bought this device off eBay (link: https://www.ebay.co.uk/itm/262446881168) and connected it up to my Alana head unit (Ibiza 2006 reg). However, when I press the CD6 button on my head unit, it just displays 'CD Changer' on the screen but the radio continues to play. I have it connected to an MP3 player but it doesn't seem to pick it up.

I read somewhere that the earth connection from the device can be temperamental (i.e. the one that connects to the screw thing at the back of the head unit), resulting in the device not working properly.

Any advice would be appreciated.

Thanks.
 
Aug 1, 2019
1
0
Hey RVP09, I've got the very same problem, have you or anyone else managed to sort it out?
 

mgrays

Active Member
Dec 9, 2006
356
6
Aberdeen
A 2005 with same headunit. I wired into the CD changer and it only worked once or twice in a lot of playing around. Not sure what/why goes wrong but they seem temperamental in some cases but not every unit. I was using the low output from an iPod so there was never too much going in there. This was in 2007 and I tried a few times since then.
 

alexh

Active Member
Mar 1, 2017
59
1
Did this adapter already have an earth on one of the pins on the connector? I think the one I bought did not and I had the same problem until I made one myself with a short piece of wire. There are instructions on an older thread on the forum but unfortunately none on the pictures are working. I will try to find the one I modified and post a picture.
 
AT Designs, Custom Badge Design for forum members