SOS Error

Jun 24, 2021
8
1
I know this has been flagged in Formentor chat, but anyone else had same issue in Leon. My 3 day old car has just given me this warning. Not happy
 
May 31, 2021
5
1
I have had the issue for a while, car has already been in for it but it hasn't been fixed, it normally follows a double clicking noise coming from the center channel speaker and it normally also causes my Google maps to freak out via Android auto

Sent from my CPH2025 using Tapatalk
 
Jun 24, 2021
8
1
Just really frustrating. Hopefully an isolated incident as I don’t want a yellow warning triangle flashing on dash regularly
 

SRGTD

Active Member
May 26, 2014
1,669
816
If you use the advanced search function - search on ‘SOS’ and restrict your search to the mk4 forum board - you'll find other discussion threads where mk4 Leon owners have had the SOS error. Mk8 Golf owners over on golfgtiforum.co.uk have also had this, so seems it’s not Leon-specific. Seem to remember someone also posted while back on the mk6 Ibiza forum that they had this issue with their new Ibiza.

Based on what I’ve read on the Golf forum, seems this can be caused by a faulty SOS emergency control module.
 
  • Like
Reactions: Tell
Jun 24, 2021
8
1
Thanks @SRGTD . Having read many of the forum posts I can see that this is a common fault, but there is a mixed bag of views as to whether or not it can be fixed and if it is hardware related. However, one post on the Golf 8 forum said that if you got to Max Privacy mode then the issue goes away. So I have now done that and will see what happens.

I don't use the SEAT Connect App or website, so I don't think I really miss out on anything by being in Max Privacy mode. What modes to other people run in (and why)?
 

Mrfamilyman

Active Member
Jun 23, 2021
6
4
Thanks @SRGTD . Having read many of the forum posts I can see that this is a common fault, but there is a mixed bag of views as to whether or not it can be fixed and if it is hardware related. However, one post on the Golf 8 forum said that if you got to Max Privacy mode then the issue goes away. So I have now done that and will see what happens.

I don't use the SEAT Connect App or website, so I don't think I really miss out on anything by being in Max Privacy mode. What modes to other people run in (and why)?
Since going to the dealers I have had no repeat of the sos and screen freezing .. loving the car now
 

KoNG

Active Member
Jul 27, 2016
352
51
Kent / Barking
Finally got my car back. Had the unit replaced and that seems to cured the problem with sos errors

Edit: double click bang through audio is still present
 
Last edited:

Kernow13

Active Member
May 22, 2021
44
4
I have had the issue for a while, car has already been in for it but it hasn't been fixed, it normally follows a double clicking noise coming from the center channel speaker and it normally also causes my Google maps to freak out via Android auto

Sent from my CPH2025 using Tapatalk
Exactly the same happened to me. Driving along the M25 the infotainment system seemed to go 'Click-Click' and then the map froze - up popped the "SOS go to workshop sign' - Well the Motorway was a "SMART" motorway so no way was I going to stop. I ignored it and drove to services (the car drove perfectly) and when I restarted there it was again. I switched off the infotainment system and when - after a couple of minutes - I restarted it the message had gone. There was nothing helpful in the Owners Manuel so I just carried on. That was several weeks ago - the car drives like a dream and has behaved itself ever-since. I did wonder if it was a temperature thing as it was an incredibly hot day? Any ideas?
 

dan555

Active Member
Sep 29, 2020
231
92
Exactly the same happened to me. Driving along the M25 the infotainment system seemed to go 'Click-Click' and then the map froze - up popped the "SOS go to workshop sign' - Well the Motorway was a "SMART" motorway so no way was I going to stop. I ignored it and drove to services (the car drove perfectly) and when I restarted there it was again. I switched off the infotainment system and when - after a couple of minutes - I restarted it the message had gone. There was nothing helpful in the Owners Manuel so I just carried on. That was several weeks ago - the car drives like a dream and has behaved itself ever-since. I did wonder if it was a temperature thing as it was an incredibly hot day? Any ideas?
I've found the infotainment screen gets really hot, without the sun. When it's in direct sunlight I couldn't touch the screen, but it was still responsive and everything worked fine
 

Kernow13

Active Member
May 22, 2021
44
4
I've found the infotainment screen gets really hot, without the sun. When it's in direct sunlight I couldn't touch the screen, but it was still responsive and everything worked fine
It did seem like an over-heating issue, but why frighting the life out of customers by screaming SOS - go to workshop. I thought the engine was about to explode!
 

FalconTech

Active Member
Jun 8, 2021
75
23
I've found the infotainment screen gets really hot, without the sun.
Some complain about the lack of air-conditioned glove box. I have the impression that the air conditioning channels should cool the inductive charger and the phone on it, as well as the display and all important modules.
 

KXL

KXL
Dec 15, 2016
1,576
195
London, UK
I have an Audi A3, a 'SOS Malfunction contact workshop' always crops up in low mobile? signal areas, near tunnels and in between high buildings. Perhaps its a VAG car issue. However it doesn't affect the driving of the car.
 

sarafianl

Active Member
May 25, 2021
22
11
Worcester Park
I've had this issue on my March 21 build xcellence lux. Not sure if it's related to heat as I've had it happen on cool mornings. Last time I was near the Deptford Bridge and it died for 15 minutes then clicked in. I heard the same centre speaker clicking for about 30 mins before it died?

There is an article on the guardian newspaper website about this fault : https://www.theguardian.com/money/2...owners-angry-over-fault-in-sos-warning-system

I've been talking to Seat uk about this problem and showed them this press article along with examples here. All they say is take it to the workshop as that's the process! Total denial about this widely known fault. Don't think I will buy a vag group car again.
 

sarafianl

Active Member
May 25, 2021
22
11
Worcester Park
Hi All,

Update I noticed around this error. Whilst driving I started getting the clicking sound from the center speaker (like others have reported) before the SOS error shows up. I happened to notice that at that exact moment of the clicking the two symbols inbeween the mobile signal and notification symbol disappeard (see pic). They were there when I started my journey. This has happened a few times this weekend with the same pattern of events. Now this indicates a loss of connection to the outside world. I clicked on the icon to bring my profile and it was stuck in a circle saying connecting. For refference I was in a high coverage area. Soon as these symptoms started, I pulled over, did a soft reboot by holding down the power button on the infotainment display, and when it rebooted it came back with all 4 notifications present and connected back to the world and no further clicking. I had not moved an inch on the road during this experience so cannot blame cell coverage. I also use my phone as a mobile hotspot for data services and problem still persists if you use this method or the eSIM. I'm convinced there is a major bug here and the VAG group won't admit it because they need to do a recall which costs them money. It's not engine affecting so I think won't bother with it. Poor!

Would be good if others who get this issue can confirm if they see the icons suddenly disappear with a loss of connection to the world.
 

Attachments

  • 20210807_171610.jpg
    20210807_171610.jpg
    276.2 KB · Views: 161

KoNG

Active Member
Jul 27, 2016
352
51
Kent / Barking
I thought my system was cured but today while driving electrical click-click sound is back and SOS system error visit workshop.

there are two scenarios for this
Failure Sequence 1
· Loud Electrical Click from the Centre Speaker
· "Error: Emergency Call. Please visit workshop error” on Instrument Cluster
· SOS Light goes off on roof
· Route guidance is not active message on Instrument Cluster
· Navigation is currently unavailable message on Instrument Cluster

Failure Sequence 2
· Loud Electrical Click from the Centre Speaker
· SOS call is now active message on Instrument Cluster
· SOS Light goes off on roof
· Route guidance is not active message on Instrument Cluster
· Navigation is currently unavailable message on Instrument Cluster

In both scenario loss connection to server (globe and user is gone)

I've seen both of them already, it's really annoying they don't know what to do with it. It is plenty discussion on VW forum about it also so it affecting all VAG car with the same series of issues.

Contacted SEAT UK about it too, but no answer there. Most useless service ever there!!
There is some recalls for Golf but nothing mentioned on SEAT!
 
Last edited:
  • Like
Reactions: sarafianl

KoNG

Active Member
Jul 27, 2016
352
51
Kent / Barking
I checked this before, but after update people are reporting same issue it is update on multimedia unit 5f to 1668. My unit is on 1672 with same issues
 
Letchworth SEAT - car sales sponsor