Cannot read ECU errors

Apr 13, 2020
1
0
Hey guys, i know this is my first post here but here's my little story.

Bought a Seat Leon Mk2 Cupra in March 2019, really low mileage car, verified and i really enjoy it.
The car has a stage1 made by a so called BMM Motorsport software reseller in my country. Car was mapped by the previous owner.

At the end of the year, i was helping a friend start up his car after his battery died so i hooked up some cables the proper way, tried to start his car, battery was so dead it wouldn't start.
I then decided it was time to quit and told him to buy a new battery. Took a look at my car while it was still running, the engine was shaking a lot, got into the car to shut it off i had a check engine light on. The car was running bad, like it was missfiring a lot.

Grabbed my VCDS and tried to look for the error and then discovered that i cannot read the engine whatsoever. I thought that it might have something with the car being turned off. Started the car, ran the scan again and the car started to go nuts. It went from normal RPM (750 RPM) to 0 and then back up, while something was clicking in the left side of the dashboard. It did so untill i canceled the scan or an error saying the engine cannot be reached popped up.

The thing is the car developed a small shake or stutter when idling and then after a few months had another missfire with a blinking check engine which then turned into a full check engine light. Took it on a platform to a specialised service, they couldn't figure it out because they cannot read the ECU.

Talked with the previous owner, gave me the phone number of the guy that mapped it, had a chat with him about the engine idling poorly sometimes and all he said was "coil packs or spark plugs" which i already replaced. He also tried to read the engine and couldn't. All we can see is when the engine is running, is pulling up different sensors, as the MAF, RPM, Lambda sensors and so on. At this point i did not trust the guy to let him try and figure it out or remap it.

I uploaded a log from january, ignore the HVAC error, it was caused by a fuse, and also the front right beam was caused by a deceased module which has already been replaced.

Any thoughts on this ? I don't really wanna remap it since this stage one puts about 310 horsepower with no lift shift and boost by gear settings, which i really like.
Please Help.
 

Attachments

Progressive Parts, performance parts and tuning specialists