Xenon power units constantly burning out(water leak)

Oct 10, 2019
37
0
Greetings, my xenon power units are constantly failing, to be exact,water is somehow getting in,whenever I pull them out,there is a burnt plastic smell and plenty of water comes out. Is there something that goes over them to prevent water getting in? I see they have some rubber gasket that goes inside the connection but it doesn't seem to help
 

Legojon

I only wanted a remap
Staff member
Moderator
Jul 7, 2015
5,182
2,630
The plastic backs (that screw on with 3 screws) sometimes crack and let water in. Let's hope it's that cause it's a cheap easy fix and worth trying first. Failing that, likely the entire headlight enclosure will need replacing to stop the water leak (not cheap). But if your burning through power packs may be the only option.
 
Oct 10, 2019
37
0
Tnx for the info, I don't think I have any plastic cover on the back of the ballasts, should there be any?
 

PaulusB

Active Member
Jun 9, 2019
132
30
I had also the same problem I replaced the 2 back covers because the gasket and mounting point where crisp.

Verstuurd vanaf mijn SM-G930F met Tapatalk
 
Oct 10, 2019
37
0
I had also the same problem I replaced the 2 back covers because the gasket and mounting point where crisp.

Verstuurd vanaf mijn SM-G930F met Tapatalk
Got a picture of it? I have no cover going over the back of the headlight where ballasts,wires and all the other stuff is located whatsoever.
 
AT Designs, Custom Badge Design for forum members