• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.
  • We're live with the new site! Please let us know what you think in this thread. Also let us know if you spot any quirks.

Common Mk4 Problems

clareiow

Guest
1.2 chill bought new in sept 2006.

Always had a knock when on full lock turning right only.

Vandalised several times so needed wing mirror replaced - never bothered putting rear wiper arm back on!!

Other than that no problems until.....

October last year I'm driving along and while it's in third lose all power thru pedal - just dies completely. Turned out it was a faulty fuel ignition and one of the coil packs going.

And now, we have another problem! Car is stalling while idling. Epc and engine light comes on, just restart the car and move on. Took it to local garage but no faults on diagnostics. Take it to seat dealership and they find another coil pack has gone. £110 later and a coil pack (and spark plugs for all three replaced) later I thought it was fixed.

Just hours later, it's happened again. At my wits end not knowing whats wrong, and want rid to be honest!!!
 

2 car dad

Active Member
Feb 21, 2012
22
0
Another planet
In 4 days of ownership the rear wash has popped off, turbo pipe popped off and the electric window switches popped in to the door handle. Oh and I can turn the radio off by hitting the top of the dash!!
Top of the pops?
 

JRLJamielin

Guest
I just bought an 08 sportrider 1.4 100

Hoping I don't get the worst of these issues, i'll let you lot know if something does go wrong! :)
 

Mr.B33J

2Tone Terror
Apr 28, 2010
71
0
Birmingham
Front Top Mount size?!

Not sure where else to ask this so I guess here is as good as any! Basically went to fit FK coilovers on my car today and it turns out the underside of my top mounts are too wide for the internal diameter of the spring?!?!? Have definitely confirmed the kit used to be on a Mk4 so I can only guess that I have non standard size top mounts :S

Searched all over the place for the outer dimension of the small sleeve around which the spring sits but cant find it anywhere. Anybody know?

thanks!
 

Mr.B33J

2Tone Terror
Apr 28, 2010
71
0
Birmingham
1.2 chill bought new in sept 2006.

Always had a knock when on full lock turning right only.

Vandalised several times so needed wing mirror replaced - never bothered putting rear wiper arm back on!!

Other than that no problems until.....

October last year I'm driving along and while it's in third lose all power thru pedal - just dies completely. Turned out it was a faulty fuel ignition and one of the coil packs going.

And now, we have another problem! Car is stalling while idling. Epc and engine light comes on, just restart the car and move on. Took it to local garage but no faults on diagnostics. Take it to seat dealership and they find another coil pack has gone. £110 later and a coil pack (and spark plugs for all three replaced) later I thought it was fixed.

Just hours later, it's happened again. At my wits end not knowing whats wrong, and want rid to be honest!!!
Had all these problems with mine last year. Replaced numerous coil packs individually. even got a full new set. In the end I replaced all coilpacks with premium ones not budget, took off the throttle body and gave the inside a good polish. Then disconnected the battery overnight and it's been fine ever since! Bit unsettled when idling in the cold of winter but perfect now. Failing that maybe lambda sensor?
 

SteArch

Guest
1.2 12V

Timing chain slipped at 77k (bent 8 out of 12 valves) - Fixed by my dad ;)

Rear wiper screenwash pipe poped off - dewipered now so just cable tied the pipe off

Driverside door seal, Windnoise - Not fixed yet but getting a new door seal

Lambda sensor - Replaced

Coilpacks - Had all 1 and 2 go, replaced and been fine since

Aircon plays up, takes ages to get cold - not fixed yet but going to try an aircon refill

:)
 

soupz

Active Member
Oct 16, 2010
86
0
Omagh, N.Ireland
Rear wiper doesn't work. I see it mentioned everywhere about the pipe popping off in the boot but mine is fine there, whereas it is spraying up in the engine bay from somewhere below the water bottle. Anyone any tips? Has a pipe come off or how do i fix it? Tried having a look with a torch but can see nothing. Need it working again for the MOT in 2 weeks... any help much appreciated.
 

FroggyLCR

Yellow Beastie
Oct 2, 2012
251
0
Norwich
Hi,

Boot and offside passenger curtosy lights not working. Near side passenger bulb works fine. Checked both bulbs and both fine. Offside passenger lights fails in both settings, door open / over ride on.

Oh and rear washer no fluid snag to, off to fix that now after reading this thread so thanks very much all. :)

(2003 LCR).
 

casualtycaz

Guest
2008/'58 plate seat Ibiza starting issues

Firstly, apologies if this is the wrong place to post, but I'm at despair. I've got the a I've car second hand but with approx. 7 months manufacturing warranty left. When the air temp gets to about 17degees plus it can often take about 3 or 4 cars to start, often starting and cutting out. I took it to garage where I brought the car and nothing found and started fine so the changed spark plugs free. All seemed well and than again it started, so a new battery, temperature sensor, fitted. Starter motor fitted by Seat dealer for free. All fine but started again :-(, so diagnostic at local garage, nothing! Than it came up recently with an "unknown code fault", had a camshaft sensor fitted on off chance but that's not worked either.
I'm all out of options, Seat want £100 plus and vat to put on their diagnostic machine. I've asked around and no one can seem to know why when its warm it doesn't start first time.
Thanks in advance if anyone knows any fixes and cheaply!!
 

BigDave67

Guest
It could be an immobilizer problem.
There is a green connector on the back of the dials that suffers dry joints, causes many problems like fuel gauge and outside temp stop working and car not starting, which I had. The heat could be making the dry joint worse. But if its that causing your car not to start you normally get the immobilizer light staying on or flashing, I can't remember exactly what mine did. it requires taking the dials out and using a soldering iron, but if it’s in warranty they just replace the whole thing.
The thread is here
http://www.seatcupra.net/forums/showthread.php?p=2211412#poststop
 

BrennyCo

Guest
Ibiza 1.9 FR 60k

Rear washer pipe popped off
Offside driveshaft broke
Clutch replaced yesterday due to an 'exploding' freewheel
Boost pipe pops off occasionally
TCS light on dashboard due to almost snapped load wire
Both anti-roll linkages replaced due to damage

Driveshaft, clutch, TCS light and linkages within a month of each other!
 

casualtycaz

Guest
G28 diagnostic code

Hi, I've had the above code and been told its the crankshaft sensor. Strange question, but there is only one sensor and not a front and rear crankshaft sensor?
Thank you in advance.
 
Apr 13, 2011
1,971
1
hull
57 plate Cupra tdi 57k miles
2.5 year of ownership

So far rear brakes corroded and binding (fitted helper springs to calipers plus groved discs)

Bottom turbo pipe blown off (replaced with up rated forge pipe)

Front ap racing calipers sticking (still need to sort)

Front mount intercooler leaking ( still to fix also)
 

RUM4MO

Active Member
Jun 4, 2008
6,085
401
South Scotland
Hi, I've had the above code and been told its the crankshaft sensor. Strange question, but there is only one sensor and not a front and rear crankshaft sensor?
Thank you in advance.
I think that you should copy this posting into the main Mk4 Ibiza area as then it will get maximum visability/chance of a response.

For what it is worth, I'd say that there is only one crankshaft sensor, having two would only let you know if the crankshaft had snapped - even then maybe not!
 

mutley170fr

Guest
faulty fuel gauge/outside temp.gauge. Long time since I posted this, but I did eventually cure the guage problem-after removing the instrument cluster I found that some of the solder joints had become dry so I re-soldered them and everything worked perfectly,and has continued to do so for the last 4 years!Hope this may be of some help to someone.
 
Last edited by a moderator:

welshmn

Active Member
Oct 24, 2012
74
0
So far my ibiza cupra tdi has got hissing sound from aircon also not very cold. Grumble sound from engine. Low revs rear lights fog up and top pipe at the left hand side of the engine blew off while overtaking not fun .
 

Priezti

Auto-Electrical Monkey!
Feb 11, 2009
119
0
Doncaster
Faults so far

6 Dial dash fault - New set of clocks, even with proper tools couldn't get them programmed in so immobiliser bypassed
2 alternators
2 Blown turbo pipes - 1 replaced at £46 1 tie wrapped to death :)
Rear wash pipe popped off in engine bay - De-wiper'd and rear wash pipe reused for SMIC water spray
Air conditioning not working - Not sure yet, might be compressor or switch
Broken springs, bushes, and whatever else
Drivers side window regulator replaced @ £40 for parts

More I can't remember
 
Last edited:
GAP Insurance - cover the difference for peace of mind