Rain/Light Sensor Coding Mk3 FR

Oct 28, 2020
2
0
ok so after a bit of googling i worked it out.

Physical Modifications

Parts needed:

RLHS Sensor: 5Q0955547A
Auto Light switch: 5G0941431AF

You'll need to swap that out by taking off the mirror, its a bit hard to see so mspaint time, the red line is the join i used a knife to separate it, then push up in the direction of the arrow, with abit of wiggling you can remove that part.



Once that's off you'll see 2 prong things on the mount, twist this towards the passenger side(anti clockwise) only needs to go about an inch and the whole mirror mount should be free.

next image taken from google as i didn't want to take it apart again


you should see the sensor now, pull out the cable at the top and unhook both left & right side clasps, then you can pull out the sensor( mine was very stiff)

supposedly you can change the gel pad under the sensor , i didn't and mine works fine. Put the RLHS in, attach clasps, plug it in and rebuild your mirror onto its mount, at this point auto wipers seem to work without any further modifications.

For the Light switch, you just need to push it in and twist clockwise slightly then it can be pulled out slowly as the cable isn't very long, unplug the cable and put in the new switch.

VCDS Coding

you need the RLHS sensor to show in the drop down as below:

if its not there, this is how to enable it.

Have the top module selected (5Q0 937 084 AJ BCM ....)

Enabling the sensor, in vcds
  1. Select 09 - Centr. Elect.
  2. Select 16 - Security Access (Note; couldn't remember if this was needed or not, don't think it matter if you put it in and its not needed)
    input 31147
  3. Select 07 - Coding
  4. Select Long Coding Helper
  5. Byte 6: bit 0-1 light sensor Installed
  6. Byte 7: bit 5 ticked
  7. Byte 7: bit 7 ticked


after this is done, the RLHS sensor with be in the dropdown list, select it and enter 00095D into the New coding Box

Now you car can correctly see the sensor you need to make the following adaptions

  1. Select 09 - Centr. Elect.
  2. Select 16 - Security Access (Note; couldn't remember if this was needed or not, don't think it matter if you put it in and its not needed)
    input 31147
  3. Select 10 - Adaptation



After this on mine i needed to actually go into the car setup menu to enable coming/leaving home

Hi,

Thanks for the great guide! After going through the hardware steps, I plugged in VCDS and was ready to add the coding onto the new sensor as per your guide. I will add some pictures to show the modules listed in the Centr. Elect. However, as you can see from the pictures there is a slight variance between my module (5Q0 937 084 CG) and your module from the pictures within your guide (5Q0 937 084 AJ).

(PICTURE)

After some digging, I found that I have installed the wrong RHLS. I have installed a (5Q0 955 547 C) and not a (5Q0 955 547 A) as per your guide. A small mistake but I assume this is why the module codes are wrong. I have tried the code the wrong module (5Q0 937 084 CG) as per your guide however, I receive this error message
  • Coding is NOT supported by this control module Variant.
  • Replacement Control Modules must be parameterized by using
  • be found by using the ‘Adaptation’ Function of the Control Module.
(PICTURE)

I believe I may have to change the sensor to (5Q0 937 084 AJ). However, I was wondering if you would know any work around’s or possible ways, I could still use the current sensor installed?
Thanks,
 

Attachments

mcspook

Active Member
Feb 11, 2020
24
11
Hi,

Thanks for the great guide! After going through the hardware steps, I plugged in VCDS and was ready to add the coding onto the new sensor as per your guide. I will add some pictures to show the modules listed in the Centr. Elect. However, as you can see from the pictures there is a slight variance between my module (5Q0 937 084 CG) and your module from the pictures within your guide (5Q0 937 084 AJ).

(PICTURE)

After some digging, I found that I have installed the wrong RHLS. I have installed a (5Q0 955 547 C) and not a (5Q0 955 547 A) as per your guide. A small mistake but I assume this is why the module codes are wrong. I have tried the code the wrong module (5Q0 937 084 CG) as per your guide however, I receive this error message
  • Coding is NOT supported by this control module Variant.
  • Replacement Control Modules must be parameterized by using
  • be found by using the ‘Adaptation’ Function of the Control Module.
(PICTURE)

I believe I may have to change the sensor to (5Q0 937 084 AJ). However, I was wondering if you would know any work around’s or possible ways, I could still use the current sensor installed?
Thanks,
For the facelift leon i think you need the 81A955555A sensor.
 
  • Like
Reactions: Mileon
Nov 17, 2020
1
0
Hi, have you got the long coding for this, I'm having the wipers issues. I have now tried 2 sensors, 81A955547A which is supposed to be for Ateca and 5Q0955555. Both great for lights but not wipers. Thanks
Hi, did you get any joy in getting this sorted? Pretty sure I've got the wrong sensor in mine (5Q0955555) where the OEM Ateca sensor is 5Q0 955547B for my 2017 car where equipped. Autolights work fine but the auto wipers originally would wipe when there was water but not switch off. Now they don't work in intermittent...
 
Dec 26, 2019
8
0
Hi, did you get any joy in getting this sorted? Pretty sure I've got the wrong sensor in mine (5Q0955555) where the OEM Ateca sensor is 5Q0 955547B for my 2017 car where equipped. Autolights work fine but the auto wipers originally would wipe when there was water but not switch off. Now they don't work in intermittent...
Yes in the end I used sensor 81A955555 which is for Ateca. 5Q sensors are for Leon facelift apparently.(mentioned somewhere else in this thread). Once I changed to the 81A955555 everything worked as should and no errors showing in climate control as I got with other sensors used. So this would seem to be the way to go with the Ateca. Enjoy
 
Progressive Parts, performance parts and tuning specialists