• We're live with the new site! Please let us know what you think in this thread. Also let us know if you spot any quirks.

Vag-com on Vista

m0rk

sarcasm comes free
Site Owner
May 19, 2001
27,784
22
Clanfield, UK
It works....

Tested with a very early version 303 on regular vista install.

Run .exe to install - once installed, right click on the icon, and select to run as WinXP SP2, 'run as administrator' and hit 'ok'

Using a pikey ebay cable, download the drivers from autonostics.com - choose the second version. download, unrar

Plug the cable in, and search for the drivers manually.

once located the cable will be installed.

once it's installed properly, you will need to:
a) remember which USB port it's plugged into - you'll always need to use this one
b) load 'System' from control panel (use the classic view) then Device manager & locate the USB-> Serial field. edit the port properties, choose the advanced field & select a COM port from 1-4 that is not 'in use'

hit OK, and go plug it into your car to test it out - remembering what COM port you chose (set this in the options of vag-com)

easy peasy
 

Mikael

Guest
I got the 409-1 software to work in Vista using the instuctions by m0rk above exept for not setting the software to work in XP SP2 mode (so just untick the box 'Run this program in compatibility mode for:').

This way the software seemed more stable as it seemed to hang in XP SP2 mode a few times.
 
Oct 11, 2008
714
0
31
Bristol
can anyone suggest a seller or cable to buy on ebay? i also have vista and need vag com (will prob buy license)

many thanks
 

ruimbt

Guest
I got the 409-1 software to work in Vista using the instuctions by m0rk above exept for not setting the software to work in XP SP2 mode (so just untick the box 'Run this program in compatibility mode for:').

This way the software seemed more stable as it seemed to hang in XP SP2 mode a few times.
Hi

Just one question, the 409.1 that you have is registered? if so how do you do it?
I cant regist mine... dont know why and cant find a crack or something.

Many thanks
 

Mikael

Guest
Hi

Just one question, the 409.1 that you have is registered? if so how do you do it?
I cant regist mine... dont know why and cant find a crack or something.

Many thanks
I downloaded the 409-1 version from http://www.ross-tech.com/vag-com/download/.

I did not use any cracks (as stated, not really legal). Using it as a shareware will however disable some functionality (e.g. does not read all 'common' faults).

Doesn't yours work?
 

Mikael

Guest
can anyone suggest a seller or cable to buy on ebay? i also have vista and need vag com (will prob buy license)

many thanks
I bought mine of ebay "lonelec".
Seem to work fine, but as I haven't got a full version of the software (only shareware) some functionality is not 100%. So I can't ensure everything works, but I don't see why not.

Hope that helps.
 

RUM4MO

Active Member
Jun 4, 2008
6,083
401
South Scotland
can anyone suggest a seller or cable to buy on ebay? i also have vista and need vag com (will prob buy license)
many thanks
If you still have not bought VAG-COM and intend to buy the "full function" - ie legal and licensed version then try Ilexa or Gendan - that would be www.onboarddiagnostics.co.uk or www.gendan.co.uk. Personally, if you intend to stick with VAG cars I'd do as I did and stick to buying the USB+CAN version, but maybe that is the only version available from the smarter VAG-COM outlets like Ilexa. Maybe if you don't need all the functions that VAG-COM offers then you might consider some of the self contained tools that Gendan and others sell.
 

gazcuprablk

my 300+ death box :)
Mar 31, 2006
858
0
south wales
have tried countless times for this now an jus comes up with com port ok interface not found! im stumped what to do about this now
 

Damoegan

Sir Bob,a geordy legend..
Oct 15, 2007
8,994
3
Newcastle
As Mark said, the driver wonte be installed correctly mate.

This is how I have done it:

Run .exe to install – (once installed, right click on the icon, and select to run as WinXP SP2, 'run as administrator' and hit 'ok') << that is just for Vista.

Using a pikey ebay cable, download the drivers from www.autonostics.com - (I have downloaded it and put it into a folder) download, unrar

Plug the cable in, and search for the drivers manually. – Before you plug the cable in save the folder with the driver in onto your desktop. Then go to Control panel > system > device manager, then plug the cable in. When you plug the cable in you will see it pop up in device manager, it will try to auto install the driver for it which you don’t want. You need to stop it installing the driver by right clicking on it and select ‘install driver manually’ and choose the folder you put on the desktop.

Once located the cable will be installed.

once it's installed properly, you will need to:
a) remember which USB port it's plugged into - you'll always need to use this one
b) load 'System' from control panel (use the classic view) then Device manager & locate the USB-> Serial field. edit the port properties, choose the advanced field & select a COM port from 1-4 that is not 'in use'
 

[email protected]

Back older greyer and less oilier but always hope
Jun 19, 2001
12,376
26
Gloucester
tested 409-1 on a pikey cable + Windows7 works

not 100% stable but works with shareware download for basics so far

(needs to be run as administrator but leave compatibility mode unchecked)
 

The MoffMeister

Half Hoff, Half Moff.
Apr 4, 2006
2,937
0
colchester
hi guys i keep bothering damien so i'll ask here also to give him a break lo

bought the cable off of ebay which came with a disc to set up with vag com so presumably i installed this instead of the one mention above me?

installed the vag com software run auto scan to get the serial number, then copied this into the options section and put it under the shop name is this right or not?

cheers
 

DPJ

...........
Dec 13, 2004
8,013
2
NN Yorks / Salento
www.seatcupra.net
My laptop screen expired so I bought a new laptop. (I got one with Vista Business installed as it came with an XP Pro downgrade disc. However, I thought I'd give vista a shot.....)

I've tried the above and I could not get my computer to recognise the driver no matter what I tried.

I let the computer try going online to find a driver - and lo and behold it did! All installed, Vag-Com found the cable on Com3, but it won't find any controllers in Vag-Com.

I tried unisettings with the cable - and it works fine. It was reporting the serial number of my ecu....

Any thoughts?
 
Mar 26, 2007
2,020
0
S.Wales
Dave, my guess is that the driver that it installed isn't quite right. It's perfectly possible to have a driver that reports as working fine but actually doesn't handle everything you need it to.

Tricky with Vag-com because it has such bespoke functionality, don't know what to suggest I'm afraid.
 

DPJ

...........
Dec 13, 2004
8,013
2
NN Yorks / Salento
www.seatcupra.net
409.1-S

I'm mystified. I uninstalled the driver the computer found and managed to install the rar version. Turned out they were the same. Still can't find any controllers. I've just fired up my old laptop on a monitor and the drivers a broadly the same.... (The version on XP shows a couple more files) :shrug:
 

DPJ

...........
Dec 13, 2004
8,013
2
NN Yorks / Salento
www.seatcupra.net
I just downloaded 311. I get - modern interface found on Com3.

But when I try to access any controller I get
Interface not ready

Possible Solutions:
Incorrect Com Port selected
Interface not plugged in
Ignition not turned on
K line stuck

The first three aren't true, the fourth unlikely. :cry:
 
Adrian Flux insurance services - discount for forum members.