LCR fuel Pump with Revo stg2. (Surging problems fixed)

__B3NNY__

OEM with a 'Twist'
May 5, 2005
3,449
0
Oxford
I`ve had my k03s running on a revo stg2 for well over a year now and ever since having the k03s fitted its pulled back on WOT from low down and surged like crazy, it got to a point where it was awful to drive and felt like it took ages to catch up with itself once it started pulling back, Bill can vouch for this and also a few of the other revo stg2 guys know what im talking about.

Yesterday i fitted my LCR fuel pump ready in advance of my hybrid, took it for a little drive last night and up to Silverstone this morning and it feels like a newly mapped car it drives superb with no surging and doesnt pull back in any gear, it drives very similar to a jabba mapped car ive been in and feels just as quick, where as before it felt really slow compared to the jabba mapped car and no where near as strong through the gears.

So what do you guys think? Could of my standard fuel pump been buggerd or on its way out, or could the LCR pump be the answer to the the problems alot of us revo stg2 lads are having.

If i didnt have all the hybrid parts here i think id keep it how it is its made that much of a difference.

Comments.
 
Last edited:

__B3NNY__

OEM with a 'Twist'
May 5, 2005
3,449
0
Oxford
I assume you where running Revo stg2 coober?

If so did you find that it would pull back like mad if you built the revs up from right low down EG when logging?

Part of me thinks my pump my have been on its way out because i could hear a faint whining noise from the rear but this had been happening for well over a year also so i would have thought it would of given up totally or logged a lean fault somwhere along the lines?

Only coverd 43k also.
 
Last edited:

SEATCOOBER

LOVE MY IBEEZA!!!
Mar 11, 2007
1,400
0
LINCOLN/NORWICH
i did have one in the engine bay but took it out because i thought it was causing my high cfs, yes partnumber and price would be good as im off down the stealers tomorrow!!
 

__B3NNY__

OEM with a 'Twist'
May 5, 2005
3,449
0
Oxford
Nah i didnt in the end, i thought it was reading a little low, i found a thread about lining up the arrow on the pump with a mark on the tank which i have now done, and it adjusted the needle abit to which i now think is correct, ill find out for sure when i fill right up.

got just under 1/4 of a tank and its reading approx 45miles left, which i think is about right?
 
Genuine SEAT Parts and Accessories.