• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.

Rain/Light Sensor Coding Mk3 FR

iby104

Active Member
Aug 2, 2017
76
10
Absolute LEGEND!!

Got the sensor and switch last August and gave up after trying OBD11 and VCDS on the long coding for about a month.

Spent 5 mins tonight in OBD11 adaptions and the everything worked, except leaving home lights. Factory reset the light settings in the the car and boom, leaving home now works.

Can’t thank you enough for finding this solution!!


Sent from my iPhone using Tapatalk
Ive repaired the faulty light switch, the foglight mechanism was jammed so i freed it and now everything works except leaving home. Il do what you said and factory reset the settings in menu.

I also noticed in the climate control display, the air clima setting doesnt activate or sync, maybe the factory reset might fix this too. Will post back tomorrow. Excited moment lol

EDIT: couldnt wait so i went out and done a factory reset. Everything is working perfect now even the clima . Ive just got to set the time to 15s or 10s for home/leaving lights

Cant thatnk you guys enough
 
Last edited:

Joee

Active Member
May 29, 2017
38
1
Ive repaired the faulty light switch, the foglight mechanism was jammed so i freed it and now everything works except leaving home. Il do what you said and factory reset the settings in menu.

I also noticed in the climate control display, the air clima setting doesnt activate or sync, maybe the factory reset might fix this too. Will post back tomorrow. Excited moment lol

EDIT: couldnt wait so i went out and done a factory reset. Everything is working perfect now even the clima . Ive just got to set the time to 15s or 10s for home/leaving lights

Cant thatnk you guys enough
Excellent mate, results all round


Sent from my iPhone using Tapatalk
 

Jim45

Active Member
Apr 27, 2018
289
83
This may be a silly question but I’ll ask anyway.

If anyone with the Chinese auto light switch mod wanted to change to the official SEAT auto lights by fitting the sensor and a new auto light switch, could they simply remove the sensor from the Chinese switch and use it as a normal auto switch?
 

Joee

Active Member
May 29, 2017
38
1
This may be a silly question but I’ll ask anyway.

If anyone with the Chinese auto light switch mod wanted to change to the official SEAT auto lights by fitting the sensor and a new auto light switch, could they simply remove the sensor from the Chinese switch and use it as a normal auto switch?
I’ve never used the Chinese auto light mod but I’m guessing it’s the one with the separate light sensor that you stick on the dash?

If it is, having a guess, I would say probably not as the sensor/switch will probably be wired differently. Again, just guessing.

If you are wanting to do the full mod of replacing the sensor then I would buy just the sensor first and try it, it might work. If not, then you would obviously need to buy a new switch to suit.


Sent from my iPhone using Tapatalk
 

iby104

Active Member
Aug 2, 2017
76
10
This may be a silly question but I’ll ask anyway.

If anyone with the Chinese auto light switch mod wanted to change to the official SEAT auto lights by fitting the sensor and a new auto light switch, could they simply remove the sensor from the Chinese switch and use it as a normal auto switch?
If you have a humidity sensor already installed, then most likely you will need to swap it with the correct original sensor(part numbers mentioned in above posts), and remove the wired light sensor from the chinese autolight switch.

I dont know how your mod switch is but you will need to make sure the light sensor wires are seperated properly.

2 different mod switches i found:

https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.co.uk/ulk/itm/152371408220

https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.co.uk/ulk/itm/382030889842

The vcds or obdeleven coding should be same for both chines switch and original, because the chinese 1 is disguised as original to the car

Sent from my SM-G930F using Tapatalk
 
  • Like
Reactions: Jim45

Jim45

Active Member
Apr 27, 2018
289
83
If you have a humidity sensor already installed, then most likely you will need to swap it with the correct original sensor(part numbers mentioned in above posts), and remove the wired light sensor from the chinese autolight switch.

I dont know how your mod switch is but you will need to make sure the light sensor wires are seperated properly.

2 different mod switches i found:

https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.co.uk/ulk/itm/152371408220

https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.co.uk/ulk/itm/382030889842

The vcds or obdeleven coding should be same for both chines switch and original, because the chinese 1 is disguised as original to the car

Sent from my SM-G930F using Tapatalk

Thanks for the reply, I asked purely out of curiosity as I currently have the Chinese version installed but I have the new sensor and correct switch on order so I will be installing them as soon as they arrive. If I can get the wires out of the car without damage I will sell on the Chinese switch.
 

vikram soni

Active Member
Jul 19, 2018
126
38
I doubt that chinese switch will work with original sensor.. because these chinese switches has its own circuitry.. thry have sensitivity control, some even have bluetooth to connect to smartphone app to control the light sensitovity

I think the auto light switch is very nice mod (without much hassle). Not because of auto lights, coz not eveyone needs auto lights but because it activates coming/leaving home.. which adds a touch of luxury.

Sent from my LG-H870DS using Tapatalk
 

iby104

Active Member
Aug 2, 2017
76
10
I doubt that chinese switch will work with original sensor.. because these chinese switches has its own circuitry.. thry have sensitivity control, some even have bluetooth to connect to smartphone app to control the light sensitovity

I think the auto light switch is very nice mod (without much hassle). Not because of auto lights, coz not eveyone needs auto lights but because it activates coming/leaving home.. which adds a touch of luxury.

Sent from my LG-H870DS using Tapatalk
Suprised they havnt added a speaker in their switch to play music from phone via bluetooth




Sent from my SM-G930F using Tapatalk
 
Last edited:

jacko5

Active Member
Jan 10, 2017
187
35
56
UK
Update,
Driving to work this morning it started to rain lightly, the wipers started to wipe when in intermittent mode on the stalk.
So i guess the rain sensor is working Ok.
Strange how i cannot see RLS on obd eleven software, just need to see if auto rain closing works now.
 
  • Like
Reactions: Jim45

iby104

Active Member
Aug 2, 2017
76
10
Update,
Driving to work this morning it started to rain lightly, the wipers started to wipe when in intermittent mode on the stalk.
So i guess the rain sensor is working Ok.
Strange how i cannot see RLS on obd eleven software, just need to see if auto rain closing works now.
Ive just been messing around with vcds, added driving school, off road and the blinking indicators, i also changed the settings for home/leaving lights from 30s to 10s. Now ive notice my auto wipers have stopped working. Will have to go through settings again :(

Sent from my SM-G930F using Tapatalk
 

jacko5

Active Member
Jan 10, 2017
187
35
56
UK
Well the light switch turned up.
Brand new in box .. nice. ( £13 odd delivered .. lucky me i think ).
Only one fog light icon on the light switch but it lights front and rear fog lights ... so all ok.
Got the auto lights to work and as i said earlier the rain sensor works.
Done the coding for coming home / leaving home but it does not work.. both don't work.
I have it enabled in the car radio menu etc.
Weird.

Part number ends in AG instead of AF hence only 1 icon for fog light instead of 2.
Its from a VW Polo.

Edit,
This is the exact switch i bought ... but a lot cheaper.
https://www.ebay.co.uk/itm/VW-POLO-...055888?hash=item1edc9957d0:g:Ma0AAOSwv~latkdr
 
Last edited:

iby104

Active Member
Aug 2, 2017
76
10
Well the light switch turned up.
Brand new in box .. nice. ( £13 odd delivered .. lucky me i think ).
Only one fog light icon on the light switch but it lights front and rear fog lights ... so all ok.
Got the auto lights to work and as i said earlier the rain sensor works.
Done the coding for coming home / leaving home but it does not work.. both don't work.
I have it enabled in the car radio menu etc.
Weird.

Part number ends in AG instead of AF hence only 1 icon for fog light instead of 2.
Its from a VW Polo.

Edit,
This is the exact switch i bought ... but a lot cheaper.
https://www.ebay.co.uk/itm/VW-POLO-...055888?hash=item1edc9957d0:g:Ma0AAOSwv~latkdr
This is what u need to do

Go into vehicle - settings - factory settings and click on light. Then switch car off and on. Home leaving will work.


With that switch u wont get front fog lights, i think its off a golf gte
 
  • Like
Reactions: vikram soni

vikram soni

Active Member
Jul 19, 2018
126
38
This is what u need to do

Go into vehicle - settings - factory settings and click on light. Then switch car off and on. Home leaving will work.


With that switch u wont get front fog lights, i think its off a golf gte
Your light switch should be in Auto position for leaving home/coming home to work.

The most important is factory reset from menu.

We can also do coding in vcds to make it dipped beam/fog/drl whatever is needed.. incase if someone wants fog lights.

Cheers!


Sent from my LG-G6 using Tapatalk
 

jacko5

Active Member
Jan 10, 2017
187
35
56
UK
Thanks chaps will give it a go.
With the switch you do get both front and rear fog lights .. at least on my car you do .. i have tried it.
But you cannot pick either front or rear like you should be able to on the proper switch.

Edit,
Done the above still does not work... weird this.

Edit2,
Went through obdeleven settings again and redid everything and now the coming / leaving home lights work.
So i can confirm the light switch i bought works fine.
 
Last edited:

Jim45

Active Member
Apr 27, 2018
289
83
Encouraging you got it all working, I assume you used the info from this thread?

Still waiting for my genuine Leon switch from Netherlands, hopefully it will arrive tomorrow.
 

jacko5

Active Member
Jan 10, 2017
187
35
56
UK
Encouraging you got it all working, I assume you used the info from this thread?

Still waiting for my genuine Leon switch from Netherlands, hopefully it will arrive tomorrow.
Yes all from this thread.
Thanks to all.
 

rcopus

Active Member
Jun 6, 2012
270
8
Midlands
So I purchased China's finest cheap bits to do this!
Sensor: 8UD.955.559.B
Switch: 5GG.941.431.D

Installed them tonight. The switch is a fake Chinese copy which doesn't have the positions in the correct orientation. I will probably replace it as it does look a bit cheap.

Coming home works, leaving home works, all positions on the switch do what they should, wipers work.

I haven't seen daylight yet but fingers crossed the lights will be off when its in sunlight!

Causes for concern are the following;
When switch is in sidelight position the dash illumination goes off completely - weird.
Air conditioning module is reporting fault 'databus missing message'.
Gateway module is reporting fault 'undefined control module'.

I expected that in central electrics module 9 I'd be able to see the new sensor as a subsystem. Instead I still see the old sensor "G397_FSS".
So its almost like the car hasn't recognised that I have replaced the sensor despite all the functions working?

I will keep my eye on the whether the windscreen ever fogs up as that would indicate the humidity sensor isn't working and maybe thats why theres an error against the air conditioning module.

Edit - another question is, I disabled the sun sensor as I was getting an error about the sunlight photo sensor. Has everyone else with climate control disabled the sun sensor too?
 

Jim45

Active Member
Apr 27, 2018
289
83
So I purchased China's finest cheap bits to do this!
Sensor: 8UD.955.559.B
Switch: 5GG.941.431.D

Installed them tonight. The switch is a fake Chinese copy which doesn't have the positions in the correct orientation. I will probably replace it as it does look a bit cheap.

Coming home works, leaving home works, all positions on the switch do what they should, wipers work.

I haven't seen daylight yet but fingers crossed the lights will be off when its in sunlight!

Causes for concern are the following;
When switch is in sidelight position the dash illumination goes off completely - weird.
Air conditioning module is reporting fault 'databus missing message'.
Gateway module is reporting fault 'undefined control module'.

I expected that in central electrics module 9 I'd be able to see the new sensor as a subsystem. Instead I still see the old sensor "G397_FSS".
So its almost like the car hasn't recognised that I have replaced the sensor despite all the functions working?

I will keep my eye on the whether the windscreen ever fogs up as that would indicate the humidity sensor isn't working and maybe thats why theres an error against the air conditioning module.

Edit - another question is, I disabled the sun sensor as I was getting an error about the sunlight photo sensor. Has everyone else with climate control disabled the sun sensor too?
I have the genuine SEAT Sensor but get the air con fault as you have but as I haven’t got my light switch yet I haven’t coded anything.

EDIT. I also have the sunlight photo sensor error. What is the effect of disabling this?

Sent from my iPhone using Tapatalk
 

rcopus

Active Member
Jun 6, 2012
270
8
Midlands
Hey Jim - apparently the sun sensor is there to monitor the thermal gain coming through the windscreen and allows the climate control to act accordingly. I'm not sure whether it also controls the dimming of the dashboard lighting too or whether thats done else where.

I don't know if having rain/light/humidity sensor means this is defunct/surplus now or not. Only way to find this is out is to ask someone that has these options from factory. Seeing as it started alarming when I installed the RLHS I can only assume its surplus.
 

Jim45

Active Member
Apr 27, 2018
289
83
Hey Jim - apparently the sun sensor is there to monitor the thermal gain coming through the windscreen and allows the climate control to act accordingly. I'm not sure whether it also controls the dimming of the dashboard lighting too or whether thats done else where.

I don't know if having rain/light/humidity sensor means this is defunct/surplus now or not. Only way to find this is out is to ask someone that has these options from factory. Seeing as it started alarming when I installed the RLHS I can only assume its surplus.
Presumably the sun sensor is combined with the humidity sensor and we replaced it with the RLHS but the car doesn’t appear to know about it.

I’m somewhat concerned about the errors because I’ve no idea if the climate is functioning correctly.

Can someone chip in & let us know how to eliminate them?


Sent from my iPhone using Tapatalk
 
Christ Knott Insurance - Competitive quotes for forum members