• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.

Rain/Light Sensor Coding Mk3 FR

iby104

Active Member
Aug 2, 2017
76
10
The rain sensor I installed has 2 sensors on it, with this I now get auto wipers.

What's the extra sensor on the pic below for? Anybody know


Sent from my SM-G930F using Tapatalk
 

vikram soni

Active Member
Jul 19, 2018
126
38
just to put it here as I struggled a little bit to remove the rear view mirror. There is a lock mechanism between the fork ( an angled shape which prevents the mirror assembly to turn anti clockwise. The correct way is to pull the mirror assembly down ( the clamps allow it to pull a little bit) and then turn it anti clickwise.
SkHkHCc-min.jpg
 
  • Like
Reactions: Jim45

vikram soni

Active Member
Jul 19, 2018
126
38
The rain sensor I installed has 2 sensors on it, with this I now get auto wipers.

What's the extra sensor on the pic below for? Anybody know


Sent from my SM-G930F using Tapatalk
this is the old model of sensor. the new one only has 2 diodes. Did a lot of searching around internet before installing myself.
 
Last edited:

iby104

Active Member
Aug 2, 2017
76
10
for guys with 2017 facelift Leon, here is the VCDS steps to code sensor for Light/Rain.


step 1 : activate automatic light switch.

Central Electronics > 10. Security , enter code 31347, Do it!
Go to Adaptation menu now, and from the dropdown select:
ENG141656-ENG141992-Außenlicht_uebergreifend-LDS_mit_AFL, set it to Yes.

View attachment 1038

Step 2: Set the Rain-light sensor installed option so that system detects the light sensor

Central Electronics > 10. Security , enter code 31347, Do it!
Go to Adaptation menu now, and from the dropdown select:
IDE8786-ENG141985-Assistance light functions-Regen_lichtsensor: LIN_REGEN_LICHT_SENSOR

After doing this step, the rain/light sensor will be visible in the Central electronics > coding dropdown.

View attachment 1039

Step 3: Code the Sensor and enable automatic light, rain light etc..

Go to Central Electronics > Coding..
Select the RLHS from dropdown, and click on long coding helper.
You should see the option to enable automatic headlights, automatic light in rain.. do as you require and the automatic lights should be working..

Now you can also enable Coming Home / Leaving home functions.. The steps are already mentioned in this thread.. so I guess no need to repeat that. its the same.

View attachment 1040
I dont see the RLHS option in the coding area, does this mean I got wrong sensor in. Will take a picture of it when i get in my car.

Also, when i install my auto light switch, I get light error, and the fog light is lit up on the switch in all settings(off auto dip and full). Ive done the above adaption for 2017 model exactly. Any suggestions? Thanks

Sent from my SM-G930F using Tapatalk
 

vikram soni

Active Member
Jul 19, 2018
126
38
I dont see the RLHS option in the coding area, does this mean I got wrong sensor in. Will take a picture of it when i get in my car.

Also, when i install my auto light switch, I get light error, and the fog light is lit up on the switch in all settings(off auto dip and full). Ive done the above adaption for 2017 model exactly. Any suggestions? Thanks

Sent from my SM-G930F using Tapatalk
could you extract the adaptation map from vcds in excel. that would help understand why you are getting light error. correct me if I am wrong, you get full-beam and dipped beam on when you put the switch to auto, and on the screen you get light error? I remember I also got this while I was using some trial and error approach.

Make sure that you have
ENG141656-ENG142034-Außenlicht_uebergreifend-Light_Control_Module not installed
 

iby104

Active Member
Aug 2, 2017
76
10
could you extract the adaptation map from vcds in excel. that would help understand why you are getting light error. correct me if I am wrong, you get full-beam and dipped beam on when you put the switch to auto, and on the screen you get light error? I remember I also got this while I was using some trial and error approach.

Make sure that you have
ENG141656-ENG142034-Außenlicht_uebergreifend-Light_Control_Module not installed
How do i extract adaptation map?

EDIT: Found it, im on it now
 

Jim45

Active Member
Apr 27, 2018
289
83
Is there a definitive guide to coding the auto wipers and lights for a Facelift using OBDEleven, apologies if I have missed it.
 

iby104

Active Member
Aug 2, 2017
76
10
could you extract the adaptation map from vcds in excel. that would help understand why you are getting light error. correct me if I am wrong, you get full-beam and dipped beam on when you put the switch to auto, and on the screen you get light error? I remember I also got this while I was using some trial and error approach.

Make sure that you have
ENG141656-ENG142034-Außenlicht_uebergreifend-Light_Control_Module not installed
Ive corrected the adaptation setting u posted, it was set to installed.

Here are the pics,


When switch is on 0 i get only the drls on. When i select auto, dip or on position, the drls main lights and fog lights are on. View attachment 1223


Sent from my SM-G930F using Tapatalk
 
Last edited:

vikram soni

Active Member
Jul 19, 2018
126
38
Ive corrected the adaptation setting u posted, it was set to installed.

Here are the pics,


When switch is on 0 i get only the drls on. When i select auto, dip or on position, the drls main lights and fog lights are on.



View attachment 1223


Sent from my SM-G930F using Tapatalk
did it fix the light fault? In the RLHS coding, you can use the long coding helper. I remember I had to select the vehicle model in Byte 1 section of long coding. ( use 06885D )

Also, if you put the light switch to position or dipped beam. it should behave same as the old switch.
 
Last edited:

iby104

Active Member
Aug 2, 2017
76
10
did it fix the light fault? In the RLHS coding, you can use the long coding helper. I remember I had to select the vehicle model in Byte 1 section of long coding. ( use 06885D )

Also, if you put the light switch to position or dipped beam. it should behave same as the old switch.
Yes i selected leon 5f, but still have the same issue. Could the switch be faulty?

My friend has a 2017 gtd, il try switch and see if it works.

Il also try out the code you've mentioned

Sent from my SM-G930F using Tapatalk
 

vikram soni

Active Member
Jul 19, 2018
126
38
Yes i selected leon 5f, but still have the same issue. Could the switch be faulty?

My friend has a 2017 gtd, il try switch and see if it works.

Il also try out the code you've mentioned

Sent from my SM-G930F using Tapatalk
Could be faulty switch also. If you can get hands on another switch, try swapping it and check how it behaves on all other modes apart from auto.
 

iby104

Active Member
Aug 2, 2017
76
10
Could be faulty switch also. If you can get hands on another switch, try swapping it and check how it behaves on all other modes apart from auto.
Does the adaptation map look ok?

Sent from my SM-G930F using Tapatalk
 

vikram soni

Active Member
Jul 19, 2018
126
38
Does the adaptation map look ok?

Sent from my SM-G930F using Tapatalk
I cannot see the file attached.

I just changed my LDS_mit_AFL configuration from Yes to No, and I am also getting the full+dipped beam with foglight along with the light fault error message. (Only when i put it in auto )

If you scroll up, you can find my previous post with link to google drive, where I have uploaded the adaptation change log and all screenshot I took for every step ( some steps were to rollback previous changes too ). I take screenshot of every change I do
 

vikram soni

Active Member
Jul 19, 2018
126
38
I think this setting is causing the error. Try changing the below configuration. it should remove the error.

ENG141656-ENG142034-Außenlicht_uebergreifend-Light_Control_Module installed. --> change to 'Not installed'
 

iby104

Active Member
Aug 2, 2017
76
10
Already on not install. This is so frustrating lol

Sent from my SM-G930F using Tapatalk
 

vikram soni

Active Member
Jul 19, 2018
126
38
Already on not install. This is so frustrating lol

Sent from my SM-G930F using Tapatalk
I have my auto lights working, also coming home and leaving home works perfectly. I run down to my garage and send you the adaptation map I have.

are you getting the light fault only when on Auto mode or in other modes too ?

EDIT: attached adaptation file, There are two worksheets in the file, Sheet 1 is from my car. Also got the screenshots for the RLHS Sensor, uploaded here.
.
light sensor long coding byte 0.PNG
light sensor long coding byte 1.PNG
 

Attachments

Last edited:

Jim45

Active Member
Apr 27, 2018
289
83
I have my auto lights working, also coming home and leaving home works perfectly. I run down to my garage and send you the adaptation map I have.

are you getting the light fault only when on Auto mode or in other modes too ?
Facelift or not?


Sent from my iPhone using Tapatalk
 
Letchworth SEAT - car sales sponsor