• Hi Guest why not show off your SEAT! (now fixed)
    You can now share your favourite car photos in the new media gallery including embedding pictures from your Instagram account.
  • Hi Guest! New high quality keyrings are now available to pre-order: order yours now.

LED lights in reg plate blowing fuse!

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Hi, I am new to cars and don't know all that much I am trying to learn as quick as I can but struggling with this one....sorry if it is a daft question!
I have tried to put LED reg plate lights in my ibiza Fr 6j (13plate) and they keep blowing the fuse (5 amp mini blade) I have replaced the fuse 3 times and each time it has instantly blown. I have checked the fuse board and it is the right size for that slot and I have read you can't put a bigger fuse than is required.
Do I have to get specific LED's for the reg plate or can it just not run LED's?
Thanks for any help!
:help::help::help:
 

RADIOTWO

Active Member
Mar 6, 2018
185
23
North Derbyshire
Hi, I am new to cars and don't know all that much I am trying to learn as quick as I can but struggling with this one....sorry if it is a daft question!
I have tried to put LED reg plate lights in my ibiza Fr 6j (13plate) and they keep blowing the fuse (5 amp mini blade) I have replaced the fuse 3 times and each time it has instantly blown. I have checked the fuse board and it is the right size for that slot and I have read you can't put a bigger fuse than is required.
Do I have to get specific LED's for the reg plate or can it just not run LED's?
Thanks for any help!
:help::help::help:
Hi Jade
First do not put a higher rated fuse that is dangerous, but do the original lamps work ok ? if so it is the LED's them selves that are at fault so get new ones.
just a point a LED lamp should draw less current than the equivalent filament lamp
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Hi Jade
First do not put a higher rated fuse that is dangerous, but do the original lamps work ok ? if so it is the LED's them selves that are at fault so get new ones.
just a point a LED lamp should draw less current than the equivalent filament lamp
Hi thanks for your help, the original ones was not that consistent either, the left one worked occasionally if I tapped it a few times so that might have been a loose connection and the right one had blew...both LED's worked when I initially put them in (checked after putting in each one) and then once they were screwed back into place properly that's when it blew the fuse?
 

RADIOTWO

Active Member
Mar 6, 2018
185
23
North Derbyshire
Hi thanks for your help, the original ones was not that consistent either, the left one worked occasionally if I tapped it a few times so that might have been a loose connection and the right one had blew...both LED's worked when I initially put them in (checked after putting in each one) and then once they were screwed back into place properly that's when it blew the fuse?
Its very difficult diagnosing faults over a computer, but sounds like you have a short, so you need to isolate the lamp holder from the car and see if it is ok then, but does seem funny that it only blows when plugged in.
Can you take any pictures to see if there is any points to show a short ?
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Its very difficult diagnosing faults over a computer, but sounds like you have a short, so you need to isolate the lamp holder from the car and see if it is ok then, but does seem funny that it only blows when plugged in.
Can you take any pictures to see if there is any points to show a short ?
My lamp holder comes completely out with no wires attached then you push it back in the slot then screw it in and until I screwed in the second one it was all working fine...I will take some pictures after work but what exactly do I need to be taking pictures of? Sorry I’m useless haha!
 

RADIOTWO

Active Member
Mar 6, 2018
185
23
North Derbyshire
My lamp holder comes completely out with no wires attached then you push it back in the slot then screw it in and until I screwed in the second one it was all working fine...I will take some pictures after work but what exactly do I need to be taking pictures of? Sorry I’m useless haha!
see if you can get a snap of the bit where the lamp goes in
 

Maypack

Ambassador for Cumberland Sausage
Apr 20, 2014
2,732
1,996
Gods Country - West Cumbria
Sorry I’m useless haha!
Not useless at all, just unsure about something which happens to us all. As has already been said it sounds like you either have a short or loose connection and/or the LED lamps you gave fitted are themselves causing the fuse to blow.

The hard bit is figuring out which.

What wattage were your original Janos and what wattage are the LED ones? You should fine the details on the lamp or it’s metal screw in holder. That may indicate the issue.
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Hi sorry for the delay been working! I'm not 100% sure on the wattage of the bulbs and not even sure which ones I need hope the photos help!
Here are some pictures...
IMG_3870.jpeg
IMG_3871.jpeg
IMG_3870.jpeg
IMG_3871.jpeg
IMG_3873.jpeg
IMG_3870.jpeg
IMG_3871.jpeg
IMG_3873.jpeg
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Not useless at all, just unsure about something which happens to us all. As has already been said it sounds like you either have a short or loose connection and/or the LED lamps you gave fitted are themselves causing the fuse to blow.

The hard bit is figuring out which.

What wattage were your original Janos and what wattage are the LED ones? You should fine the details on the lamp or it’s metal screw in holder. That may indicate the issue.
Can you see on the pictures the wattage? I don't know where to find that information
 

Sharpy

This place has cost me a fortune....
Oct 2, 2018
938
481
Okay... so an odd one but il share what happened to me... my Leon has the same bulb carriers. I put in LED bulbs in and for a while they worked, they then stopped, but didn’t throw a blown bulb issue.

I tried new LEDs and they didn’t work, but they did throw an error on the dash. I replaced them with a normal filament bulb and they worked and reset the dash error.

I’ve decided to stay with them... could be a similar issue?


Sent from my iPhone using Tapatalk
 

Sharpy

This place has cost me a fortune....
Oct 2, 2018
938
481
I am based in Hull, I did pop into halfords but the guy didn't know what the issue was he said the bulb may be too big
I’m in Hayton, about 30mins away happy to help if I can, Halfords are a mixed bag these days. But if you need some help troubleshooting I’m more than happy.


Sent from my iPhone using Tapatalk
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
Okay... so an odd one but il share what happened to me... my Leon has the same bulb carriers. I put in LED bulbs in and for a while they worked, they then stopped, but didn’t throw a blown bulb issue.

I tried new LEDs and they didn’t work, but they did throw an error on the dash. I replaced them with a normal filament bulb and they worked and reset the dash error.

I’ve decided to stay with them... could be a similar issue?


Sent from my iPhone using Tapatalk
That might be a good suggestion even though they were costing me a fortune!
I have had to replace the bulbs in the reg twice within 4 months that's why I moved on to LED's to see if they last any longer but apparently not!
Thanks
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
I’m in Hayton, about 30mins away happy to help if I can, Halfords are a mixed bag these days. But if you need some help troubleshooting I’m more than happy.


Sent from my iPhone using Tapatalk
I am a bit busy this week but if I haven't resolved the problem by then I will drive through to you for some help if that is alright haha thanks!
 
  • Like
Reactions: Sharpy

jdmsx

Away washing the car
A lot of the ibizas suffer from blowing the fuse when using LED bulbs, but if you buy the full LED unit from ebay then there are no problems. I encountered this problem when I first got my ibiza, tried 2 types of bulbs and both blew the fuse, then bought the full LED units and have had no problems since putting them in!
 

Jade

Active Member
Nov 20, 2018
17
2
Hull, Yorkshire
A lot of the ibizas suffer from blowing the fuse when using LED bulbs, but if you buy the full LED unit from ebay then there are no problems. I encountered this problem when I first got my ibiza, tried 2 types of bulbs and both blew the fuse, then bought the full LED units and have had no problems since putting them in!
Yeah I have thought of doing that but I can't seem to find any that look as though they would fit...all the ones on ebay have wires attached but in my holder there is no where to plug in the wires don't suppose you can send me a link to the right ones could you?
 
Nimbus hosting - Based solely in the UK.